Closed Bug 1354093 Opened 6 years ago Closed 6 years ago

header: 'Reply-to' not being honoured if mailing list or more than one email addess.

Categories

(Thunderbird :: Untriaged, defect)

45 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1309486

People

(Reporter: anjeyelf, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323110425

Steps to reproduce:

Version 52
Select an email with following headers.
FROM, REPLY-TO, TO, SUBJECT.

If the 'Reply-to' header is a simple email address eg: no-reply@mozilla then all works as expected. So this is not about those particular emails.

This bug occurs when the 'Reply-to' is a mailing list address or there is more than one email address separated by a comma. Such as one I received recently when TB council elections were running.
This bug was not an issue in version 45.8.0

Click on 'Reply' button



Actual results:

new Write window opens and the 'TO' field is populated with the email address as identified in the 'FROM' field. The 'Reply-to' field is not honoured.

If the 'Reply-to' happens to be a mailing list email address, then 'Reply' button is not honouring it, although the 'Reply-List' button does. 
However, it strips the 'text' part in front of the email address.
eg: name of person/group <email addess>
displayed in TO field as email address only.

but if there are two 'Reply-to' email addresses, then the first in the list is ignored and so is all the text part as explained above, so only the last email address is inserted.


Expected results:

clicking on 'Reply' button should use whatever is included in a 'Reply-to' header field by default, assuming a 'Reply-to' header is included.
If there is more than one 'Reply-to' email address separated by a comma, then both should be placed in 'TO' fields.
Text part prior to <email address> should be included not stripped.

This bug is starting tobe reported in the Support Forum.
eg:
https://support.mozilla.org/t5/Thunderbird/Changed-in-52-0-when-replying-to-a-mailing-list-reply-will-be/m-p/1386812/highlight/false#M147550
Summary: header: 'Reply-to' is not being honoured. → header: 'Reply-to' not being honoured if mailing list or more than one email addess.
Yes, this behaviour has changed in bug 77304. It it mentioned in the release notes:
https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/
  When replying to a mailing list, reply will be sent to address in From
  header ignoring Reply-to header
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Ok thanks for the heads up on release note explaining change.
That explains why clicking 'Reply' ignores a 'Reply-to' field if it is a Mailing List.
But it also ignores an ordinary email address if there is more than one separated by comma or if the second one is a mailing list.
Workaround valid option - just in case anyone else reads this as info.
In the case of having more than one email address in a 'Reply-to' field:
'Reply-all' option will insert both 'Reply-to' email addresses and mailing list correctly.

So the end result means 'Reply' will only use the 'Reply-to' if it contains only one ordinary email address.
Making all complaints a dupe of bug 1309486 now.
Resolution: INVALID → DUPLICATE
You need to log in before you can comment on or make changes to this bug.