Shutdown ping is not sent if the browser is updated

RESOLVED WORKSFORME

Status

()

Toolkit
Telemetry
RESOLVED WORKSFORME
10 months ago
10 months ago

People

(Reporter: Abe_LV, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox55 affected)

Details

(Reporter)

Description

10 months ago
Steps to Reproduce:

1. Download and install Nightly build of 2017-04-04: https://archive.mozilla.org/pub/firefox/nightly/2017/04/2017-04-04-03-02-04-mozilla-central/firefox-55.0a1.en-US.win32.installer.exe

2. Start the browser from clean profile
3. Set[add] the following prefs:
    toolkit.telemetry.enabled -> true
    toolkit.telemetry.server -> <url of the local telemetry server, e.g.
    http://localhost:8080>
    toolkit.telemetryshutdownPingSender.enabled -> true
4. Wait until the infobar shows
5. Let the browser restarts by applying the updates 
6. Check if ping is received by the telemetry server
7. Close the browser
8. Check if shutdown ping is received by the server

Actual Result:
Shutdown ping is not received by telemetry server


Expected Result:
Shutdown ping should be received by telemetry server

Screen Capture: https://testing-1.tinytake.com/sf/MTQ4OTYzNl81MjI4NzI3
(Reporter)

Updated

10 months ago
Blocks: 1336360
Flags: needinfo?(alessio.placitelli)
(Reporter)

Comment 1

10 months ago
The pref "toolkit.telemetryshutdownPingSender.enabled" should have been "toolkit.telemetry.shutdownPingSender.enabled". 
With the correct pref the issue is not reproducible.

Closing as works for me.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(alessio.placitelli)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.