Additional security of banks is no longer recognized by Firefox 52.0.2

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: leonardo, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

I use internet banking with Caixa Economica and Banco do Brasil in Brazil.

https://internetbanking.caixa.gov.br/SIIBC/index.processa and https://www2.bancobrasil.com.br/aapf/login.jsp

They require a security program to be downloaded to be able to access their internet banking. However, the additional security is no longer recognized by Firefox 52.0.2 on any windows (7, 8.0, 8.1 and 10). In version 52.0.1 it worked without any problem.



Actual results:

The additional security is installed but Firefox does not access the banks. Internet Explorer works normally.


Expected results:

I should have been able to access their site after the security program was installed.
The difference between 52.0.1 and 52.0.2 was negligible, a couple of stability bugs. Maybe you mean it worked in 51.0 and didn't work in 52.0.2? That might be because we stopped supporting NPAPI plugins, but that's just a guess without having a copy of the security software to check out.

There's not enough information in this bug to make progress. Perhaps you can work with the folks at https://support.mozilla.org/ to investigate and gather more detail about what, specifically, isn't working.
Group: firefox-core-security

Comment 2

2 years ago
Brazil banks have in the past used either Java or a custom NPAPI plugin. Those are no longer supported beginning with Firefox 52. We've been working with banks to stop using this technology, just as Chrome stopped supporting it long ago. We are not going to fix this in Firefox; it needs to be fixed by those sites.

As a temporary solution you can install Firefox ESR 52, which will continue to support plugins for another year or so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
You need to log in before you can comment on or make changes to this bug.