Sender name with special characters will cause incorrect email if you hit reply

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Jesse Houwing, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020401
BuildID:    2002040103

I've got a friend who's called andré.

If I receive an email from him and hit reply then only <andr> is entered as
emailaddress in the to: field.

Reproducible: Always
Steps to Reproduce:
1. send an email with a sendername with special characters
2. hit reply


Actual Results:  only the characters up to the special characters are entered in
the to field

Expected Results:  the whole name and emailaddress should be entered
(Reporter)

Comment 1

16 years ago
I see this with many more people from various countries. and the name also whows
up wrong in my inbox (as andr kamphuis instead of andré kamphuis). I can however
send an email to "andré" if I type the name myself in the to field...

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: olgam → esther

Comment 2

16 years ago
anyway, in mozilla 1.1 (win2k), when creating  a new email account, you can not
input your name with special characters, such as andré.

Comment 3

16 years ago
Mozilla 1.1b nightly build 
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020901
but it works well when i reply a email which sender name is andré.@sun.com
Product: Browser → Seamonkey

Comment 4

13 years ago
*** Bug 290738 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Assignee: sspitzer → mail

Comment 5

12 years ago
The following is much likely linked to this bug:

When replying to a sender with special characters (umlauts etc...) such as
Michael Bähr <mb@home.com> , two replies are created:

Michael

and

Bähr <mb@home.com>

The first entry is obviously causing rejected with an "Invalid Address" error message, the second works, though being corrupted.

This bug seems to be around for a long time now. Any ideas if or when it'll be solved?

Cheers

Comment 6

12 years ago
Ralfito: that's bug 254519 (via bug 292603). And so is the dupe.

This bug itself seems WFM, using thunderbird latest branch build /linux.
->WFM, but if someone still sees it, feel free to reopen.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.