When enabling compact mode, the rightmost tab is hidden on the right and the tabstrip scroll buttons aren't updated (due to the changes in spacing in the tab/titlebar)

VERIFIED FIXED in Firefox 58

Status

()

defect
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: clement.lefevre, Assigned: dao)

Tracking

({nightly-community})

unspecified
Firefox 59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox58 fixed, firefox59 fixed)

Details

(Whiteboard: [mozfr-community])

Attachments

(3 attachments)

When switching from standard theme to compact ones in nightly on Mac OS X, the rightmost tab is mostly hidden on the rightand the arrow besides it doesn't have the look showing you can slide tabs. Shadow isn't here either.

See joined screenshot: pretty much nothing more than the favicon is visible.
Might be related to bug https://bugzilla.mozilla.org/show_bug.cgi?id=1354225
See Also: → 1354225
Whiteboard: [mozfr-community]
Summary: When switching from standard theme to compact ones in nightlyon Mac OS X, the rightmost tab is mostly hidden on the right → When switching to a compact theme on Mac OS X, the rightmost tab is hidden on the right and the tabstrip scroll buttons aren't updated (due to the changes in spacing in the tab/titlebar)
Will be fixed by bug 1349555 and bug 1350210.
Depends on: 1349555, 1350210
(In reply to Dão Gottwald [::dao] from comment #2)
> Will be fixed by bug 1349555 and bug 1350210.

Both of these are fixed, but at least on 57 on Windows, I now just see this issue when switching densities. Can we reuse this bug to address that, or is there another bug on file already? (I can't find one with bugzilla searching, though I could have sworn I saw something semi-recently...)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(dao+bmo)
Resolution: --- → WORKSFORME
Eh, didn't mean to close this, oops.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
How do you still reproduce it Gijs?
For my part I can't anymore as you can't switch between compact and normal in about:addons anymore.

However I noticed another bug now by switching densities in the "Customize…" mode: when switching from compact to normal density, right border of the customize tab disappear. See the joined screenshot for that.

That's the same kind of issue that was visible in bug 1390025.
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Clément Lefèvre from comment #5)
> However I noticed another bug now by switching densities in the "Customize…"
> mode: when switching from compact to normal density, right border of the
> customize tab disappear. See the joined screenshot for that.

Yes, this is effectively a similar bug, I believe. I see a worse effect when switching to/from 'touch' density (not available on macOS). The cause is still the same: changes in the sizing of items in/around the tabstrip which cause the tabstrip to scroll in one direction or another without the corresponding events firing.
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → dao+bmo
Blocks: 1417248
Status: REOPENED → ASSIGNED
Component: Theme → Tabbed Browser
Flags: needinfo?(dao+bmo)
OS: Unspecified → All
Hardware: Unspecified → All
Summary: When switching to a compact theme on Mac OS X, the rightmost tab is hidden on the right and the tabstrip scroll buttons aren't updated (due to the changes in spacing in the tab/titlebar) → When enabling compact mode, the rightmost tab is hidden on the right and the tabstrip scroll buttons aren't updated (due to the changes in spacing in the tab/titlebar)
Comment on attachment 8928492 [details]
Bug 1354332 - Update the tab bar layout when the UI density changes.

https://reviewboard.mozilla.org/r/199746/#review205400

Seems good, thanks!
Attachment #8928492 - Flags: review?(jhofmann) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/034443b19f2b
Update the tab bar layout when the UI density changes. r=johannh
https://hg.mozilla.org/mozilla-central/rev/034443b19f2b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
Was the fix supposed to be present in 20171116220410?
If yes, then I'm still able to reproduce the issue when switching from compact to normal density.
Otherwise I'll wait for the next build.
Flags: needinfo?(aciure)
Comment on attachment 8928492 [details]
Bug 1354332 - Update the tab bar layout when the UI density changes.

Approval Request Comment
[Feature/Bug causing the regression]: Firefox 57 compact mode
[User impact if declined]: pinned tabs are misaligned when enabling compact mode
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: pretty straightforward fix
[String changes made/needed]: /
Attachment #8928492 - Flags: approval-mozilla-beta?
Hi Clément,
Can you help check if this was fixed in the latest nightly again?
Flags: needinfo?(clement.lefevre)
(In reply to Gerry Chang [:gchang] from comment #13)
> Hi Clément,
> Can you help check if this was fixed in the latest nightly again?

Yes it is now fixed.
Status: RESOLVED → VERIFIED
Flags: needinfo?(clement.lefevre)
Flags: needinfo?(aciure)
Comment on attachment 8928492 [details]
Bug 1354332 - Update the tab bar layout when the UI density changes.

Fix a misaligned pinned tabs issue when enabling compact mode and was verified. Beta58+.
Attachment #8928492 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.