failed android nightly due to duplicate files

RESOLVED DUPLICATE of bug 1324045

Status

()

enhancement
RESOLVED DUPLICATE of bug 1324045
2 years ago
2 years ago

People

(Reporter: aki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I think we have an allowlist somewhere.
This is probably because we added new locales, so these files aren't allowlisted on m-c.

[task 2017-04-06T22:09:45.841070Z] 22:09:45     INFO -  22:09:45     INFO -  WARNING: Found 119 duplicated files taking 1236225 bytes (807962 compressed)
[task 2017-04-06T22:09:45.841261Z] 22:09:45     INFO -  22:09:45     INFO -  ERROR: The following duplicated files are not allowed:
[task 2017-04-06T22:09:45.841447Z] 22:09:45     INFO -  22:09:45     INFO -  chrome/hi-IN/locale/hi-IN/browser/searchplugins/list.json
[task 2017-04-06T22:09:45.841630Z] 22:09:45     INFO -  22:09:45     INFO -  chrome/mai/locale/mai/browser/searchplugins/list.json
[task 2017-04-06T22:09:45.841815Z] 22:09:45     INFO -  22:09:45     INFO -  chrome/ff/locale/ff/browser/searchplugins/amazon-fr.xml
[task 2017-04-06T22:09:45.841999Z] 22:09:45     INFO -  22:09:45     INFO -  chrome/son/locale/son/browser/searchplugins/amazon-fr.xml
[task 2017-04-06T22:09:45.842219Z] 22:09:45     INFO -  22:09:45     INFO -  /home/worker/workspace/build/src/toolkit/mozapps/installer/packager.mk:41: recipe for target 'stage-package' failed

https://public-artifacts.taskcluster.net/V6GCKcVGQ8SmyPJba1iEDw/0/public/logs/live_backing.log
We will likely need to extend mobile/android/installer/allowed-dupes.mn

[task 2017-04-06T21:59:50.236267Z] 21:59:50     INFO -  /home/worker/workspace/build/src/obj-firefox/_virtualenv/bin/python /home/worker/workspace/build/src/toolkit/mozapps/installer/find-dupes.py <snip> -f /home/worker/workspace/build/src/mobile/android/installer/allowed-dupes.mn ../../../dist/geckoview
The patch to fix is in bug 1324045.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1324045
You need to log in before you can comment on or make changes to this bug.