crash when sending page

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: gabor.liptak, Assigned: sspitzer)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
2002040103

happened multiple times:

talkback
TB4819654X
TB4815521H

The mail code seemed to have become very unstable since my latest update ...

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 1

17 years ago
Gabor, we definitely need more info:  is this for any message you send? do you
have HTML or plain text mails option on? does it still happen if you delete
"component.reg" in your mozilla/ folder, and with a new profile?

CC stephend for talkback ID retrieval.
(Reporter)

Comment 2

17 years ago
I have seen it when using the "Send Page" (as an attachment) only
I have plain text mode on
As it is random, I won't be able to reproduce it on demand
Hopefully the talkback does provide useful information 

<rant>
I'm inclined not to send any talkbacks at all, as at seems that talkbacks cannot
be used to identify and fix non-reproducible problems ...
</rant>
Gabor - I'm not sure where you gathered that impression from, but it's highly
incorrect.  Talkback is one of the most vital tools we have.

nsCSSFrameConstructor::ContentAppended
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 8434]
StyleSetImpl::ReParentStyleContext
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1351]
PresShell::ReconstructStyleData
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5361]
nsEventListenerManager::RemoveAllListeners
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
162]
nsXBLResourceLoader::NotifyBoundElements
[d:\builds\seamonkey\mozilla\content\xbl\src\nsXBLResourceLoader.cpp, line 256]
CSSLoaderImpl::LoadStyleLink
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1443]
MediumEnumFunc
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1085]
nsVoidArray::EnumerateForwards
[d:\builds\seamonkey\mozilla\xpcom\ds\nsVoidArray.cpp, line 909]
EnumerateMediaString
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1062]
CSSLoaderImpl::InsertSheetInDoc
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1166]
CSSLoaderImpl::InsertChildSheet
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1211]
CSSLoaderImpl::LoadSheet
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1242]
EnumerateMediaString
[d:\builds\seamonkey\mozilla\content\html\style\src\nsCSSLoader.cpp, line 1016]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 163]
nsJARChannel::OnDataAvailable
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 640]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 213]
PL_DestroyEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 624]
PL_InitEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 569]
_md_CreateEventQueue [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1137]
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
mozilla.exe + 0x69bf (0x004069bf)
kernel32.dll + 0x1eb69 (0x77e7eb69)
kernel32.dll + 0x3bb86 (0x77e9bb86) 

Comment 4

17 years ago
Gabor, I strongly suspect what you are seeing is a layout bug, which would imply
the page you send does matter.  Can you give us a URL, that you always crash on,
when you send it?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

17 years ago
"Gabor, we definitely need more info:  is this for any message you send? do you
have HTML or plain text mails option on? does it still happen if you delete
"component.reg" in your mozilla/ folder, and with a new profile?"

When you asks so many questions on how to reproduce the bug, than one may think
that the talkback information was not sufficient?

I seem to have daily two-three crashes these days, but most of them I'm not sure
what to steps to reproduce are (hence I do not send a talkback ...)

I also have 

http://bugzilla.mozilla.org/show_bug.cgi?id=109299

open for quite a while:

------- Additional Comment #1 From Matthias Versen (Matti) 2001-11-09 09:11 -------

Reporter:
You crashed and you have send a Talkback Report ?
How do you crashed ?
Can you poste the talkback ID ?
(run "mozilla\bin\components\talkback.exe)


This bug is invalid without more informations ...


------- Additional Comment #2 From Gabor Liptak 2001-11-09 10:44 -------

TB37787129Y

I thought one can at least look at the stack trace if the location is 
available ...



------- Additional Comment #3 From Matthias Versen (Matti) 2001-11-09 10:50 -------

Sure we can extract the Stack trace from your crash but we need more informations. 
What have you done before you crashed ?

CC Stephend for TB37787129Y

(Reporter)

Comment 6

17 years ago
I was finally able to send it after I installed 2002040403, and I cannot seem to
reproduce it again with this current setup. Sorry I'm not sure which page was it
exactly.

Comment 7

17 years ago
Talkback is one way to pin down the problem, but indeed it's not enough to solve
a whole bug. I general when filing bugs, please provide as much context and
information you can provide - this helps a lot when we try to fix it.

Now, what URL do you regularly crash on, when you "Send Page" on it?
(Reporter)

Comment 8

17 years ago
As I just mentioned, I cannot seem to reproduce the problem with this current
setup. 

Comment 9

17 years ago
I also don't have this crash. Let's check following builds, it could be wfm.

Comment 10

17 years ago
Did not crash with Mozilla 1.1b
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020901
This hasn't crashed since 8/26.

Note that the stack is in CSS code, so there may have been strict CSS crashers
independant of Mail/News, so this might've stopped crashing here long before then.

Marking wfm.

http://climate/reports/VeryFastSearchStackSigNEW.cfm?stacksig=nsCSSFrameConstructor%3A%3AContentAppended
Status: NEW → RESOLVED
Last Resolved: 16 years ago
QA Contact: olgam → stephend
Resolution: --- → WORKSFORME
verified, per talkback.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.