The translation textarea should use target language direction

RESOLVED DUPLICATE of bug 1190566

Status

RESOLVED DUPLICATE of bug 1190566
2 years ago
2 years ago

People

(Reporter: dr.khaled.hosny, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Currently it seems that the translation text area uses the direction of the first string bidi character, so text starting with a right-to-left character will have right-to-left direction and be right aligned, and vice versa.

But this is problematic for translations since strings often start with placeholders that might contain left-to-right characters forcing the text to always have left-to-right direction even if it is mostly Arabic text. This can make editing right-to-left text rather hard and error-prone specially when more than one placeholder (or other left-to-right characters) are present in the text, as bidirectional re-ordering rules will give very confusing order and totally unrelated to how the text will be ordered in actual use.

I suggest a hardcoded direction be used for the textarea based on the target language.
We have a pretty lengthy discussion about this in bug 1190566, so I'm marking this one as dupe. Let's continue there.

It seems like we finally have the majority opinion lean towards replacing dir=auto with dir=current_locale_dir. ;)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1190566
You need to log in before you can comment on or make changes to this bug.