Sync devices are not displayed in the list after Sync and background

RESOLVED DUPLICATE of bug 1371192

Status

()

Firefox for iOS
General
P3
normal
RESOLVED DUPLICATE of bug 1371192
7 months ago
a month ago

People

(Reporter: SimonB, Unassigned)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios9.0, fxios-v7.0 affected, fxios-v8.0 affected)

Details

(Whiteboard: [nicetohave][MobileCore])

(Reporter)

Description

7 months ago
Build: BuddyBuild #2396
DeviceL: iPad Air 2
iOS: 10.3.1

Steps to reproduce:
1. Log in to FxA on desktop and device
2. Go to History 
3. Tap on Sync devices (Desktop is displayed in the list)
4. Go to Menu -> Settings
5. Tap Sync
6. Tap Home button to background Firefox
7. Restore Firefox

Actual results:
- The list of sync devices will not be displayed.

See a video of the issue:
- https://www.youtube.com/watch?v=yYPtG_gfPDU

Note:
- On mobile, I also managed to reproduce this issue by backgrounding Firefox and restoring a few times. See a video here: https://www.youtube.com/watch?v=Hr0q2cY9_x4
tracking-fxios: ? → 8.0+
Priority: -- → P3
Whiteboard: [nicetohave]
This is quite possibly a DB-backgrounding race; I've seen this myself (and commented on this) before.

Updated

5 months ago
tracking-fxios: 8.0+ → 9.0
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1371192

Updated

a month ago
Whiteboard: [nicetohave] → [nicetohave][MobileCore]
You need to log in before you can comment on or make changes to this bug.