Allow preset queries to override the last sort order

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Query/Bug List
P2
enhancement
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: Jussi Sirpoma, Assigned: Dawn Endico)

Tracking

2.15
Bugzilla 2.18

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
It would be nice, if you could have preset queries that would not use the
lastorder parameter. 

This would be helpfull in situations, where you always want to have a preset
query sorted by for example importance. Currently, the previously used sort
order will be the first one (the only one?) used.
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.18

Comment 1

16 years ago
This seems to be a regression bug, not an RFE for 2.18. This works currently 
on b.m.o, but not on landfill's bugzilla-tip nor a fresh cvs-tip installation. 
I don't know when this was broken. Could this be something as old as 1.157 
(Myk's templatisation)?

I quickly checked out the buglist.cgi code and it's quite logical that it 
won't work: the only FORM{'order'} instance is way before runnamed is operated 
on (through LookupNamedQuery and ProcessFormFields). Unfortunately I don't 
have the competence to patch right now.

Ccing justdave for consideration: I think this should be fixed before 2.16rc1 
gets out, since this used to work. Ccing Myk for comments on the possible 
templatisation stuff; cvsblame hints at you possibly knowing something about 
this?
I'll defer to the people who worked on that, but unless it's an easy fix and can
be done in the next 6 hours it's not going to make rc1.
OS: Linux → All
Hardware: PC → All
Created attachment 82932 [details] [diff] [review]
patch v1: this might fix the problem
Created attachment 82938 [details] [diff] [review]
patch v2: actually fixes problem

Ok, this time I actually tested the patch and verified that it fixes the
problem.
Comment on attachment 82938 [details] [diff] [review]
patch v2: actually fixes problem

2xr= justdave

but get rid of the tabs before you check it in.

don't forget to check it in both on the trunk and BUGZILLA-2_16-BRANCH
Attachment #82938 - Flags: review+
Checked in on trunk and 2.16 branch.  Resolving fixed.

Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.170; previous revision: 1.169
done


Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.169.2.1; previous revision: 1.169
done
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.