Closed Bug 1354496 Opened 3 years ago Closed 2 years ago

53.0b9 --> 53.0b10 version bump failed with 'WARNING - Version bumping skipped due to conflicting values'

Categories

(Release Engineering :: Release Automation: Other, defect, P1, major)

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1366916

People

(Reporter: nthomas, Unassigned)

References

Details

Attachments

(1 file)

Log is at http://mozilla-release-logs.s3.amazonaws.com/mozilla-beta/firefox-53.0b9/build1/firefox_mozilla-beta_version_bump-all-K54RKUtBRi-JjznRLcYDcg-0 and contains

07:49:39     INFO - [mozharness: 2017-04-04 14:49:39.808445Z] Running bump_postrelease step.
07:49:39     INFO - Running main action method: bump_postrelease
07:49:39     INFO - Reading from file /builds/slave/rel-m-beta-fx_version_bump-000/build/mozilla-beta/browser/config/version_display.txt
07:49:39     INFO - Contents:
07:49:39     INFO -  53.0b9
07:49:39  WARNING - Version bumping skipped due to conflicting values
07:49:39     INFO - [mozharness: 2017-04-04 14:49:39.809746Z] Finished bump_postrelease step (success)

We still got a tag, but the missing version bump should probably have been an ERROR and blown up the task.
Looks like the error is related to a string comparison at https://dxr.mozilla.org/mozilla-beta/rev/15eeffc957863531c7fc42ef8b0a39406b0a195e/testing/mozharness/scripts/release/postrelease_version_bump.py#164, where '0b10' is less than '0b9'.
See Also: → 1344229
Comment on attachment 8855740 [details]
Bug 1354496 - recover from version bump failure after 53.0b9,  a=release

https://reviewboard.mozilla.org/r/127656/#review130316
Attachment #8855740 - Flags: review?(jlorenzo) → review+
Severity: normal → major
Priority: -- → P1
We can probably use `parse_version()` from pkg_resources, which is a part of setuptools. We need to verify if it's installed by default or install it explicitly otherwise.
For the record, 53.0b10 -> b11 was bumped manually (see bug 1355018 comment 3)
See Also: → 1355018
Duping forwards to the 54.0b9/b10 failure, where aki has a patch.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1366916
You need to log in before you can comment on or make changes to this bug.