Firefox build should recognize Solaris

RESOLVED FIXED in Firefox 55

Status

defect
RESOLVED FIXED
2 years ago
8 months ago

People

(Reporter: petr.sumbera, Assigned: petr.sumbera)

Tracking

52 Branch
mozilla55

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Firefox should provide support for build on Solaris OS like it does for others.
Posted patch Bug1354510.patch (obsolete) — Splinter Review
Attachment #8855756 - Flags: review?(mh+mozilla)
Component: Untriaged → Build Config
Comment on attachment 8855756 [details] [diff] [review]
Bug1354510.patch

Review of attachment 8855756 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/moz.configure/init.configure
@@ +616,5 @@
> +def target_is_solaris(target):
> +    if target.kernel == 'SunOS':
> +        return True
> +
> +set_define('XP_SOLARIS', target_is_solaris)

This doesn't really feel necessary, unless it's going to be used (which it currently isn't)

::: ipc/chromium/src/build/build_config.h
@@ +32,4 @@
>  #define OS_NETBSD 1
>  #elif defined(__OpenBSD__)
>  #define OS_OPENBSD 1
> +#elif defined(__sun__) || defined(__sun)

You can leave out __sun, since constants.py expects __sun__ only.
Attachment #8855756 - Flags: review?(mh+mozilla)
Posted patch Bug1354510.patch (obsolete) — Splinter Review
I have one XP_SOLARIS use in queue so I have added it to the patch. And removed __sun.
Attachment #8855756 - Attachment is obsolete: true
Attachment #8856842 - Flags: review?(mh+mozilla)
(In reply to Petr Sumbera from comment #3)
> Created attachment 8856842 [details] [diff] [review]
> Bug1354510.patch
> 
> I have one XP_SOLARIS use in queue so I have added it to the patch. And
> removed __sun.

Can you remove https://dxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/moz.build#91-93 then?
Attachment #8856842 - Attachment is obsolete: true
Attachment #8856842 - Flags: review?(mh+mozilla)
Attachment #8856932 - Flags: review?(mh+mozilla)
Attachment #8856932 - Flags: review?(mh+mozilla) → review+
Keywords: checkin-needed
Assignee: nobody → petr.sumbera
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d99f00376b25
Firefox build should recognize Solaris. r=glandium
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d99f00376b25
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 55 → mozilla55
You need to log in before you can comment on or make changes to this bug.