Crash in AppDelegate.applicationDidEnterBackground(UIApplication) -> ()

RESOLVED FIXED

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios-v7.1 affected, fxios7.1+)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Stack trace:

0   Client                              0x00000001001e508c specialized AppDelegate.applicationDidEnterBackground(UIApplication) -> () (AppDelegate.swift:376)
1   Client                              0x00000001001dd600 @objc AppDelegate.applicationDidEnterBackground(UIApplication) -> () (AppDelegate.swift:0)
2   UIKit                               0x00000001877b7984 __47-[UIApplication _applicationDidEnterBackground]_block_invoke + 184
3   UIKit                               0x0000000187893638 +[UIViewController _performWithoutDeferringTransitions:] + 128
4   UIKit                               0x00000001877b7878 -[UIApplication _applicationDidEnterBackground] + 100
5   UIKit                               0x00000001877b7e00 -[UIApplication _handleApplicationDeactivationWithScene:shouldForceExit:transitionContext:completion:] + 692
6   UIKit                               0x00000001877af708 -[UIApplication workspaceShouldExit:withTransitionContext:] + 320
7   FrontBoardServices                  0x000000018324b92c __FBSSERIALQUEUE_IS_CALLING_OUT_TO_A_BLOCK__ + 36
8   FrontBoardServices                  0x000000018324b798 -[FBSSerialQueue _performNext] + 176
9   FrontBoardServices                  0x000000018324bb40 -[FBSSerialQueue _performNextFromRunLoopSource] + 56
10  CoreFoundation                      0x0000000181622b5c __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 24
11  CoreFoundation                      0x00000001816224a4 __CFRunLoopDoSources0 + 524
12  CoreFoundation                      0x00000001816200a4 __CFRunLoopRun + 804
13  CoreFoundation                      0x000000018154e2b8 CFRunLoopRunSpecific + 444
14  UIKit                               0x00000001875957b0 -[UIApplication _run] + 608
15  UIKit                               0x0000000187590534 UIApplicationMain + 208
16  Client                              0x00000001000a2994 main (main.swift:0)
17  libdyld.dylib                       0x00000001805315b8 start + 4

The code at AppDelegate.swift:376 mentions it is a weird workaround for a bug. Unfortunately not a Bugzilla bug number but I think it is fair to assume this workaround has been with us for a long time.

A lot has changed in our app and in iOS/WebKit, so I would like to suggest that we simply remove this workaround code.
(Assignee)

Comment 1

2 years ago
Created attachment 8856313 [details] [review]
PR https://github.com/mozilla-mobile/firefox-ios/pull/2613

Removed an old workaround that is appearing in our top 10 crashes.
Assignee: nobody → sarentz
Attachment #8856313 - Flags: review?(fpatel)
(Assignee)

Updated

2 years ago
Attachment #8856313 - Flags: review?(sleroux)
Its been around for a year. Here is the original bug https://bugzilla.mozilla.org/show_bug.cgi?id=1218827

And the follow up to remove the workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1247115

There has been 0 movements on the rdar. But I'll use the original bug to see if we can still reproduce this.
It doesnt crash for me in the simulator. On both 9.0 and 10.0

Updated

2 years ago
Attachment #8856313 - Flags: review?(fpatel) → review+
(Assignee)

Comment 4

2 years ago
Landed on v7.x and master.
Attachment #8856313 - Flags: review?(sleroux)
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.