Tab bar rendering glitch

RESOLVED WORKSFORME

Status

()

Toolkit
Themes
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: COOLPRASH, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8856303 [details]
ActiveTabGlitch

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Open any website on any tab. A darker theme can make this bug more visible.


Actual results:

On the active/selected tab, the rendering of the tab bar is glitchy. The glitch is graphical as one can see a rectangular bar around the page title (tab bar). This began since Firefox 52.


Expected results:

The active tab bar should not produce that glitch, and be similar to the non-active tabs which do not have that glitch when hovered over by cursor. Pre Firefox 52 versions did not produce this glitch. You can very clearly see this using a dark theme as the default theme highlights it very slightly.

Comment 1

a year ago
Which them are you using?
Does it appear with the default theme?
Flags: needinfo?(coolprash_07)
(Reporter)

Comment 2

a year ago
(In reply to Loic from comment #1)
> Which them are you using?
> Does it appear with the default theme?

Im using a dark theme to make this glitch more visible. Theme is named "Nissan GTR black", but any dark theme makes it visible.
I noticed this on the default theme at first but its not easy to notice it with a light theme.
Flags: needinfo?(coolprash_07)

Comment 4

a year ago
Created attachment 8857575 [details]
FF52-dark-theme.jpg

I can't reproduce it with FF52 32/64b on Win 7.

Ciprian, are you able to reproduce the issue on Windows 10 with the theme I provided in my previous comment?
Flags: needinfo?(ciprian.muresan)

Updated

a year ago
Component: Untriaged → Themes
Product: Firefox → Toolkit
Created attachment 8857777 [details]
screenshot_tab_bar.png

User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID 	20170412030252

I wasn't able to reproduce the issue on the Firefox Release (52.0.2, Build ID 20170323105023) or on the latest Nightly 55.0a1. 

Coolprash, could you please retest the issue using a clean new profile, maybe even safe mode to eliminate custom settings as a possible cause.
Flags: needinfo?(ciprian.muresan) → needinfo?(coolprash_07)
> Coolprash, could you please retest the issue using a clean new profile,
> maybe even safe mode to eliminate custom settings as a possible cause?

That was supposed to be a question. :)
(Reporter)

Comment 7

a year ago
Thank you for your time in looking into this matter. I was busy over the weekend configuring Windows 10 Creators update on my PC. The problem no longer exists after a clean install of the OS and FF52. I believe this might have been a glitch with my graphics driver.
Once again thank you for the quick responses and action on my bug report. This bug can be deleted. If I need to do this from my end, let me know how.
Regards.
Flags: needinfo?(coolprash_07)

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.