--spsProfile doesn't work from try syntax

RESOLVED DUPLICATE of bug 1390084

Status

defect
RESOLVED DUPLICATE of bug 1390084
2 years ago
10 months ago

People

(Reporter: kmag, Assigned: igoldan)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PI:August])

+++ This bug was initially created as a clone of Bug #1333167 +++

+++ This bug was initially created as a clone of Bug #1257570 +++

> This seems to be broken again:

This seems to be broken again again.

Apparently bug 1340267 renamed the option to --geckoProfile, but the try parser still only knows about --spsProfile. So on Windows this *sort of* works with "mozharness: --geckoProfile", except that all of the jobs fail with 4 NetworkError exceptions[1], and then timeout without uploading any profiler artifacts. On Linux, it doesn't appear to be possible to get profiler data at all.

[1]: https://treeherder.mozilla.org/logviewer.html#?job_id=89974944&repo=try&lineNumber=1663
I filed this same bug last week in bug 1354279.
Depends on: 1295644, 1354279
Whiteboard: [PI:June]
Whiteboard: [PI:June] → [PI:July]
:igoldan, is this a bug that you would like to pick up and work on?
Flags: needinfo?(ionut.goldan)
Whiteboard: [PI:July] → [PI:August]
Yes, I'm going to fix it.
Flags: needinfo?(ionut.goldan)
Assignee: nobody → ionut.goldan
:kmag I actually think this bug got fixed. Have you experienced any more problems with the --geckoProfile flag? If not, I'll mark this as FIXED.
Flags: needinfo?(kmaglione+bmo)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1390084
Flags: needinfo?(kmaglione+bmo)
You need to log in before you can comment on or make changes to this bug.