No checkboxes displayed in about:addons details tab for Instant Multi Search webextension

RESOLVED DUPLICATE of bug 1354336

Status

WebExtensions
Compatibility
RESOLVED DUPLICATE of bug 1354336
a year ago
29 days ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

({regression})

55 Branch
regression

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fix-optional)

Details

[Affected versions]:
Firefox 55.0a1 (2017-04-10)


[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with a clean profile.
2.Install the following webextension: https://addons-dev.allizom.org/en-US/firefox/addon/instant-multi-search/
3.Go to addon details tab from Addons Manager.

[Expected Results]:
All the Categories elements are correctly displayed: https://www.screencast.com/t/W5zH3Tgc4Q


[Actual Results]:
“Default” checkboxes are not displayed in add-ons details tab from about:addons.
See screenshot: https://www.screencast.com/t/UL5IkL9z  


[Regression Range]:
Last good revision: 6d38ad302429c98115c354d643e81987ecec5d3c
First bad revision: 9a26ed658fdc1d14c6153451e7e45f6ec94292fb
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6d38ad302429c98115c354d643e81987ecec5d3c&tochange=9a26ed658fdc1d14c6153451e7e45f6ec94292fb
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 418833
I’m a bit confused why this bug was marked as a duplicate of Bug 418833, considering the issue reported here is a recent regression and only Firefox 55 is affected while Bug 418833 seems to be fixed on both Firefox 54 and Firefox 55. 

Because the regression list is too long I could not figure out which bug introduced this issue.

Kris, can you please clarify this situation?
Flags: needinfo?(kmaglione+bmo)
Eyeballing the list, I would guess that this was caused by bug 1275287
Should this be marked as dupe of bug 1354336 instead?
Let's track this issue in the duplicate bug.
status-firefox55: affected → fix-optional
Duplicate of bug: 1354336

Updated

4 months ago
Flags: needinfo?(kmaglione+bmo)

Updated

29 days ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.