Enter key not working properly on webpage.

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
11 months ago
10 months ago

People

(Reporter: victor50, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

When playing http://www.freecell.net/f/c/dgame.html at the end of a game pressing enter would ok the result and another enter would start a new game.


Actual results:

I guess since a FF update this stopped working. Then, most probable after another update it worked again. Now in 52.0.2 it stopped working again. 


Expected results:

At the end of a game pressing enter should ok the result and another enter should start a new game

Comment 1

11 months ago
WFM with FF52. During a game, if I press enter, the game asks me to give up. And when I see the "play" button, pressing enter starts the game.

Could you test with a fresh profile, please.
https://support.mozilla.org/t5/Install-and-Update/Use-the-Profile-Manager-to-create-and-remove-Firefox-profiles/ta-p/2914
Flags: needinfo?(victor50)
(Reporter)

Comment 2

11 months ago
I tried a fresh profile and then it worked as expected. Then I disabled Tab Mix Plus and it also worked. Reenabled Tab Mix Plus 
and deleted some shortcut keys that conflicted with other add-ons/FF (enter key not among them). Now it works properly again. I am not sure if just switching on and off would have been enough. Still seems odd this worked for years, then two month ago stopped working, one month ago worked again and two weeks ago stopped working. When you finish the game properly you're asked to continue (showing your score). Be aware that freecell.net is "draining workplace productivity since 1996"!
Flags: needinfo?(victor50)

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

10 months ago
Sorry but it gets more complicated. The bug returned. Then I started in safe mode: Enter key worked as it should. Restarted normal: Enter key still working normal! Can you reopen?
You need to log in before you can comment on or make changes to this bug.