Bug 1355196 (work_queue_.empty)

Intermittent netwerk/test/unit_ipc/test_channel_id.js | application crashed [@ MessageLoop::DeletePendingTasks()] after Assertion failure: work_queue_.empty()

RESOLVED FIXED

Status

()

Core
IPC
--
critical
RESOLVED FIXED
11 months ago
6 months ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

({crash, intermittent-failure})

unspecified
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(crash signature)

Flags: needinfo?(jsnajdr)
I think this not a necko specific bug.
Component: Networking → IPC

Updated

10 months ago
Duplicate of this bug: 1361937

Updated

10 months ago
Duplicate of this bug: 1362481

Updated

10 months ago
Duplicate of this bug: 1361522

Updated

10 months ago
Duplicate of this bug: 1361816
The channel ID type was changed from UUID string to uint64 in bug 1348462. Landed in m-c on 2017-04-04, this bug reported few days later, on 2017-04-10. Random coincidence or not?
Flags: needinfo?(jsnajdr) → needinfo?(hurley)
Duplicate of this bug: 1373392

Comment 8

8 months ago
1 failures in 814 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-06-12&endday=2017-06-18&tree=all

Comment 9

8 months ago
2 failures in 892 pushes (0.002 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 1
* autoland: 1

Platform breakdown:
* windows8-64: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-06-19&endday=2017-06-25&tree=all

Comment 10

8 months ago
1 failures in 718 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-06-26&endday=2017-07-02&tree=all
Locally reproducible, there is only one task that remains in the queue:

base::ObjectWatcher::Watch



The whole expand of the work queue:

-		work_queue_	{ size=1 }	std::queue<MessageLoop::PendingTask,std::deque<MessageLoop::PendingTask,std::allocator<MessageLoop::PendingTask> > >
+		c	{ size=1 }	std::deque<MessageLoop::PendingTask,std::allocator<MessageLoop::PendingTask> >
-		[Raw View]	{c={ size=1 } }	std::queue<MessageLoop::PendingTask,std::deque<MessageLoop::PendingTask,std::allocator<MessageLoop::PendingTask> > >
-		c	{ size=1 }	std::deque<MessageLoop::PendingTask,std::allocator<MessageLoop::PendingTask> >
+		[allocator]	allocator	std::_Compressed_pair<std::_Wrap_alloc<std::allocator<MessageLoop::PendingTask> >,std::_Deque_val<std::_Deque_simple_types<MessageLoop::PendingTask> >,1>
-		[0]	{task={mRawPtr=0x02c7c970 {watcher=0x00000000 <NULL> object=0x000005c0 wait_object=0x0bf3f990 ...} } ...}	MessageLoop::PendingTask
-		task	{mRawPtr=0x02c7c970 {watcher=0x00000000 <NULL> object=0x000005c0 wait_object=0x0bf3f990 ...} }	nsCOMPtr<nsIRunnable>
-		mRawPtr	0x02c7c970 {watcher=0x00000000 <NULL> object=0x000005c0 wait_object=0x0bf3f990 ...}	nsIRunnable * {base::ObjectWatcher::Watch}
-		[base::ObjectWatcher::Watch]	{watcher=0x00000000 <NULL> object=0x000005c0 wait_object=0x0bf3f990 ...}	base::ObjectWatcher::Watch
+		mozilla::Runnable	{mRefCnt={mValue=1 } _mOwningThread={mThread=0x00d67290 } mName=0x195e7e8c "ObjectWatcher::Watch" }	mozilla::Runnable
+		watcher	0x00000000 <NULL>	base::ObjectWatcher *
		object	0x000005c0	void *
		wait_object	0x0bf3f990	void *
+		origin_loop	0x028afd70 {type_=TYPE_IO (2) id_=2 work_queue_={ size=1 } ...}	MessageLoop *
+		delegate	0x00d5edd4 {...}	base::ObjectWatcher::Delegate *
		did_signal	true	bool
+		nsISupports	{...}	nsISupports
+		delayed_run_time	{ticks_=0 }	base::TimeTicks
		sequence_num	0	int
		nestable	true	bool
+		[Raw View]	{...}	std::deque<MessageLoop::PendingTask,std::allocator<MessageLoop::PendingTask> >
Flags: needinfo?(wmccloskey)
(Note: we should duplicate all "MessageLoop::DeletePendingTasks" crash bugs to this one)

Comment 13

7 months ago
1 failures in 720 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-beta: 1

Platform breakdown:
* windows8-64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-07-10&endday=2017-07-16&tree=all
Duplicate of this bug: 1380767
Alias: work_queue_.empty
Duplicate of this bug: 1371069
Duplicate of this bug: 1371102
Duplicate of this bug: 1205195
Duplicate of this bug: 1371986
Duplicate of this bug: 1236350
Duplicate of this bug: 1372455
Duplicate of this bug: 1262416
Duplicate of this bug: 1372756
Duplicate of this bug: 1373510
Duplicate of this bug: 1373871
Duplicate of this bug: 1379709
Carrying ni from bug 1338878 here.
Flags: needinfo?(jmathies)
Duplicate of this bug: 1338878
Duplicate of this bug: 1339426
Duplicate of this bug: 1381170
Duplicate of this bug: 1352719
Duplicate of this bug: 1359596
Note that there has been some more investigation done in bug 1380530.

Updated

7 months ago
Depends on: 1380530

Comment 33

7 months ago
16 failures in 822 pushes (0.019 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* mozilla-inbound: 10
* autoland: 6

Platform breakdown:
* windows2012-32: 7
* windows7-32: 5
* windows2012-64: 3
* windows7-32-vm: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-07-17&endday=2017-07-23&tree=all
It looks like this might have stopped (presumably because of bug 1380530).
Flags: needinfo?(wmccloskey)

Updated

7 months ago
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Flags: needinfo?(jmathies)
Flags: needinfo?(hurley)
Resolution: --- → FIXED
status-firefox55: --- → unaffected
status-firefox56: --- → fixed
status-firefox-esr52: --- → unaffected

Comment 35

6 months ago
1 failures in 924 pushes (0.001 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 1

Platform breakdown:
* windows2012-32: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1355196&startday=2017-09-04&endday=2017-09-10&tree=all
You need to log in before you can comment on or make changes to this bug.