Closed Bug 1355219 Opened 4 years ago Closed 4 years ago

stylo: build-time bindgen doesn't work on mac with llvm 4.0

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

Unspecified
macOS
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1349479

People

(Reporter: erahm, Unassigned)

References

Details

+++ This bug was initially created as a clone of Bug #1335302 +++

As part of setting up to build stylo today I ran into the requirement for llvm-config. I installed the latest release (4.0.0) from llvm.org [1]. That didn't work, so I followed the instructions from the build setup etherpad [2] and ran:

> brew install llvm

That also had build failures. After some back and forth I figured out that installing 3.9.1 fixes things:

> brew install llvm@3.9

We should either add a proper check for whatever version we require during config or update bindgen to support 4.0.

[1] http://releases.llvm.org/download.html
[2] https://public.etherpad-mozilla.org/p/stylo
I think it is duplicate to Bug 1349479.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1349479
You need to log in before you can comment on or make changes to this bug.