Canceling the Page Setup dialog results in an error

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: mozilla7, Assigned: rods)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9) Gecko/20020310
BuildID:    2002031005

Using 0.9.9 on Mac OS X with no printer selected (I'm still waiting on drivers
from Epson or Apple), I get an error when canceling the Page Setup dialog.

Reproducible: Always
Steps to Reproduce:
1. Go to File, Page Setup
2. Click Cancel

Actual Results:  Get an error

Expected Results:  Not get an error

Error looks like this:

BrowserPrintSetup [Exception... "Component returned failure code: 0x80004004
(NS_ERROR_ABORT) [nsIPrintOptions.ShowPrintSetupDialog]" nsresult: "0x80004004
(NS_ERROR_ABORT)" location: "JS frame ::
chrome://communicator/content/utilityOverlay.js :: goPageSetup :: line 139"
data: no]
(Reporter)

Comment 1

17 years ago
Created attachment 77730 [details]
Screen shot of error

In case I made any typos in transcribing the error message.

Comment 2

17 years ago
Reporter, can you please fetch a nightly build for your platform at:

http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk

and re-test to see if it already has been fixed? Report back your findings here.

Comment 3

17 years ago
WorksForMe using FizzillaCFM/2002041712 (RC1). No error dialog is displayed
after cancelling the Page Setup dialog.
Severity: normal → major

Comment 4

17 years ago
marking WFM..REOPEN if you still see a problem after installing new build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.