Scrollbar moves in opposite direction by 1px sometimes

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
P3
normal
RESOLVED WORKSFORME
8 months ago
3 months ago

People

(Reporter: 684sigma, Unassigned)

Tracking

({regression})

55 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55 fix-optional)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

8 months ago
I found a problem in Nightly 55. It doesn't happen in Beta 53.
Sometimes when scrolling a scrollable area up, scrollbar moves down, and vice versa. Here's how to reproduce it:

1. Open http://www.htmlgoodies.com/beyond/php/show-progress-report-for-long-running-php-scripts.html
2. Find the block of code containing text "//long_process.php". 
3. If it's not scrollable, add CSS rule "height: 105.4px !important;" to the div#highlighter_160787 that contains that block
4. Drag scrollbar up and down several times

Result: When mouse moves up, the block scrolls up by 1px, but scrollbar goes down.
When mouse moves down, the block scrolls down by 1px, but scrollbar goes up.

Expected: Scrollbar should follow mouse cursor
(Reporter)

Updated

8 months ago
Has STR: --- → yes
Keywords: regression
(Reporter)

Comment 1

7 months ago
Mozregression-gui generated this regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4cbc57e29e25e8abe783b16915bd74325a040b02&tochange=d7518eef6b8924b4ddad6cdeeae4eed1c6129b26
->
1324117 – Enable APZ scrollbar dragging on Nightly
https://bugzilla.mozilla.org/show_bug.cgi?id=1324117
Blocks: 1324117
Has Regression Range: --- → yes
Component: Untriaged → Panning and Zooming
Product: Firefox → Core
status-firefox52: --- → unaffected
status-firefox53: --- → affected
status-firefox54: --- → affected
status-firefox55: --- → affected
This is nightly only, requires apz.drag.enabled. I can repro on Windows.
Blocks: 1211610
Status: UNCONFIRMED → NEW
status-firefox52: unaffected → ---
status-firefox53: affected → ---
status-firefox54: affected → unaffected
Ever confirmed: true
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → All
Whiteboard: [gfx-noted]
status-firefox52: --- → unaffected
status-firefox53: --- → unaffected
(marking as fix-optional for 55 since this is a nightly-only feature and blocks 1352312, which is the bug to ship by default)
status-firefox55: affected → fix-optional
(oops... blocks 1211610)
684sigma, do you still see this problem?

When I try follow the STR today, I'm finding that adding the rule "height: 105.4px !important;" no longer makes the div scrollable. Changing that to "105" instead of "105.4" does, but the scrolling behaviour is then correct, i.e. it moves in the right direction.
Flags: needinfo?(684sigma)
I verified that this appears fixed. I can still repro the problem on the 2017-04-11 build but cannot repro it in the latest nightly.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(684sigma)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.