Awesome bar suggestions should be sorted by times visited

RESOLVED DUPLICATE of bug 1239708

Status

()

RESOLVED DUPLICATE of bug 1239708
2 years ago
4 months ago

People

(Reporter: dukevinjduke, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170410004019

Steps to reproduce:

Press a single character in the awesome bar to your favorite site, and press enter to go to it. Instead, a site which I visited once is being listed.

Example: http://i.imgur.com/3KwRMJp.png 
I visited Vegas.com once, I visit the The Verge every day but now pressing 'v' brings up an option I've visited once. 

Also with the new autocomplete, I cannot click on 'Delete' to remove entries in awesome bar, need to click "forget this site" to delete it.
(Reporter)

Comment 1

2 years ago
Forgot to mention in the example, the site being suggested was visited once a year ago and previously there was another site on the top position that also was similar but I "Forgot about this site" to remove it. Maybe an algorithm can be implemented that takes into account which option is selected when a certain input is used? That way the awesomebar can learn based on previous user actions, since it's okay to suggest vegas.com initially.

Updated

2 years ago
Component: Untriaged → Location Bar
Autofill currently uses "typed", we have plans to improve the algorithm.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239708
You need to log in before you can comment on or make changes to this bug.