[P3P] Implement APPEL, a standard to import p3p preferences

RESOLVED WONTFIX

Status

()

Core
Networking: Cookies
--
enhancement
RESOLVED WONTFIX
16 years ago
11 years ago

People

(Reporter: Sam Schinke, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This might alleviate some of the complexity issues with p3p as third parties can provide complete p3p preferences to be imported.

http://www.w3.org/TR/P3P-preferences

It's still not a final draft, but I imagine once the framework is in (if it isn't already!) adjusting to any changes in the p3p draft should be pretty simple.

This also (maybe) gives a good form for saving current p3p pref's. Cookie control per-site stuff can be exported and shared using APPEL, and such-like.

Comment 1

16 years ago
confirming.  somewhat related to bug 128639.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: PC → All

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.2alpha

Comment 2

16 years ago
I'm an author of the APPEL spec. We are not planning to do any more work on 
APPEL (at least for a while), so please use the 15 April 2002 draft. Several 
implementers have used it and found it to be a useful way to represent user 
preferences, although we clearly shouldn't expect end users to use it 
themselves. The AT&T Privacy Bird http://privacybird.com has a modified APPEL 
implementation. JRC has a full implementation and has some source code 
available. See http://p3p.jrc.it/

Updated

16 years ago
Target Milestone: mozilla1.2alpha → mozilla1.3alpha

Comment 3

16 years ago
Is this bug going anywhere? It hasn't been updated since July.
I think that this is a *key* feature for those of us concerned with our privacy.
Can't the code be pulled from netscape, because they allow P3P cookie managing
and may use the needed code.
Target Milestone: mozilla1.3alpha → ---

Comment 4

15 years ago
taking P3P bugs
QA Contact: tever → gbush
APPEL is a P3P preference exchange language. You can set your P3P preferences
without it.

Netscape 7 supports a little bit of P3P, and that code was checked into Mozilla
last week although it is not yet built by default.
Assignee: morse → harishd
Status: ASSIGNED → NEW
Component: Cookies → XML
Keywords: helpwanted
Target Milestone: --- → Future
per discussion with mvl and dwitte, moving bugs in our p3p impl to
nobody@mozilla.org and adding helpwanted keyword

moving to Cookies
Assignee: harishd → nobody
Component: XML → Cookies
Priority: P3 → --
QA Contact: agracebush → cookieqa

Updated

14 years ago
Summary: Implement APPEL, a standard to import p3p preferences → [P3P] Implement APPEL, a standard to import p3p preferences
Target Milestone: Future → ---

Comment 7

11 years ago
p3p has been permanently cvs removed, marking wontfix.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.