Implement new tab closing animation

RESOLVED DUPLICATE of bug 1355588

Status

()

enhancement
P4
normal
RESOLVED DUPLICATE of bug 1355588
2 years ago
3 months ago

People

(Reporter: jaws, Assigned: Felipe)

Tracking

55 Branch
Points:
3
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox55 affected)

Details

(Whiteboard: [reserve-photon-animation][tabs-p2])

Attachments

(1 attachment, 1 obsolete attachment)

Posted video Tab - Close.mp4 (obsolete) —
See attached video for what this should look like.
Flags: qe-verify+
Priority: -- → P2
QA Contact: jwilliams
Summary: Tab closing should use the photon animation curve → Implement new tab closing animation
note: the new animation uses the photon motion curve.
Summary: Implement new tab closing animation → Implement new Photon tab closing animation
Summary: Implement new Photon tab closing animation → Implement new tab closing animation
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Iteration: --- → 55.4 - May 1
Priority: P2 → P1
Iteration: 55.4 - May 1 → 55.5 - May 15
Iteration: 55.5 - May 15 → 55.6 - May 29
This is on hold until the curves are removed from the tab shape.
Assignee: jaws → nobody
Status: ASSIGNED → NEW
Iteration: 55.6 - May 29 → ---
Priority: P1 → P2
Priority: P2 → P3
Whiteboard: [photon-animation] → [reserve-photon-animation]
Whiteboard: [reserve-photon-animation] → [reserve-photon-animation][tabs-p2]
Priority: P3 → P4
QA Contact: jwilliams → stefan.georgiev
Posted file Close Tab Motions
I've attached new updated versions of the close tab animations.

Folder includes motions for...

1. Tab Close Outer and Unselected
2. Tab Close Selected Inner Tab

I also included slow motion versions of each to make the subtle details easier to catch.

Once we have someone working on these I can give give a detailed walk-through of what's happening in each.
Attachment #8857139 - Attachment is obsolete: true
(Assignee)

Updated

8 months ago
Assignee: nobody → felipc
Status: NEW → ASSIGNED
(Assignee)

Updated

3 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1355588
(Assignee)

Updated

3 months ago
No longer blocks: 1352117
You need to log in before you can comment on or make changes to this bug.