2 bugs, both related to selection boxes.

RESOLVED DUPLICATE of bug 108127

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 108127
16 years ago
16 years ago

People

(Reporter: Prometheus, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I'm not sure how this system works and if i'm allowed html tags, so i've 
created my own html page and put it on my web server for you all to see. I hope 
I have placed this in the proper component, I just chose what looked most 
sensible to me.

anyway, the link is http://www.liquidgraphics.com/mozilla-bugs

Thanks.

Comment 1

16 years ago
first of all, you should file different bugs for different issues.

second of all, always put data in the bug and not in an outside address.

what if someone wants to see this bug a month from now and the URL doesn't work?

the first issue is bug 95826
and i can't reproduce the second issue

Comment 2

16 years ago
I can reproduce the second issue (btw, I'm note quite
sure this is an issue).

This comes from the style="width:85px" in <select class=textBox style="width:85px">
When this style is used, highlighting of the options stops at the last
significant char of the option while, with no style=width, highlighting goes
through the entire width of the select box.
Please, can somebody with good english reformulate the previous sentence.

A CSS expert is needed here (though I think it is a bug). CC'ing BZ

Attaching a testcase

Comment 3

16 years ago
Created attachment 77838 [details]
test case

Comment 4

16 years ago
note: the attachment test case works fine in linux 0.9.9 and linu trunk 2002040422

your explanation was just fine. 
(Reporter)

Comment 5

16 years ago
It's not the css width. Your test case worked perfect for me in both selection 
box examples. It's the table surrounding it, I'm sure of that now. Put it in a 
table and it'll mess up the selection width.
(Reporter)

Comment 6

16 years ago
Nevermind, you're right. It's the css width. Will this issue be fixed in the 
next version possibly? This issue doesn't occur in any other browser.

Comment 7

16 years ago
this is a duplicate of 108127

Prometheus, bug 108127 is marked 'Future' thus there's no ETA on when it will be
fixed.

*** This bug has been marked as a duplicate of 108127 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.