Closed Bug 1355762 Opened 3 years ago Closed 3 years ago

stylo: enable stylo in non-HTML documents

Categories

(Core :: CSS Parsing and Computation, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1370508

People

(Reporter: heycam, Unassigned)

References

Details

In nsLayoutUtils::SupportsServoStyleBackend, we currently only return true if a document is a content document and is an HTML or XHTML document (and if the pref is true).
A lot of the failures and crashes are XUL-related. Can we start with just SVG? That should hopefully make this as easy as a 1-line change in SupportsServoStyleBackend and annotating a bunch of SVG tests.
Note that there is some XUL in video controls that we'll need to deal with, but it should be much more limited than the surface that the XUL reftests is testing.
Assignee: nobody → cam
Priority: -- → P1
Here's a summary of the test failures with an updated try run, after bug 1342559 landed:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f716e94dd0f9017093d65a045c940a19ec2fcf2f

dom/smil/crashtests/690994-1.svg
layout/reftests/svg/smil/** (150 tests)
layout/reftests/svg/text/textLength-6.svg
layout/reftests/svg/mask-type-04.svg
  lack of SMIL support (bug 1302948)

layout/reftests/bugs/220165-1.svg
layout/reftests/bugs/490177-1.svg
layout/reftests/svg/foreignObject-form-theme.svg
  button not using native theming (bug 1349651)

layout/reftests/scoped-style/scoped-style-019.svg
layout/reftests/scoped-style/scoped-style-dynamic-012.svg
layout/reftests/scoped-style/scoped-style-dynamic-013.svg
layout/reftests/scoped-style/scoped-style-dynamic-014.svg
layout/reftests/scoped-style/scoped-style-dynamic-015.svg
layout/reftests/scoped-style/scoped-style-dynamic-015.svg
  lack of <style scoped> support (bug 1345702)

layout/reftests/svg/sizing/scrollbars-01.svg
layout/reftests/svg/sizing/scrollbars-02.svg
layout/reftests/svg/outer-svg-border-and-padding-01.svg
  scroll bars not working (bug 1321769)

layout/reftests/svg/text/pseudo-first-line.svg
layout/reftests/svg/text/pseudo-first-line-2.svg
  lack of ::first-line support (bug 1324619)

layout/reftests/svg/moz-only/xbl-grad-ref--grad-in-resources-01.svg
layout/reftests/svg/moz-only/xbl-grad-ref--grad-in-resources-02.svg
  something to do with XBL and resolving local url() references (no bug)

layout/reftests/svg/conditions-07.svg
layout/reftests/svg/dynamic-conditions-01.svg
layout/reftests/svg/dynamic-conditions-02.svg
layout/reftests/svg/dynamic-conditions-03.svg
layout/reftests/svg/dynamic-conditions-04.svg
layout/reftests/svg/dynamic-conditions-06.svg
layout/reftests/svg/dynamic-conditions-09.svg
layout/reftests/svg/dynamic-conditions-10.svg
layout/reftests/svg/dynamic-conditions-13.svg
  dynamic changes to conditional processing attributes aren't handled --
  maybe we're not correctly generating/processing the ReconstructFrame
  hint in nsSVGElement::GetAttributeChangeHint?  (no bug)

layout/reftests/svg/currentColor-01.svg
layout/reftests/svg/currentColor-02.svg
layout/reftests/svg/currentColor-03.svg
layout/reftests/svg/use-02-extref.svg
  fill="currentColor" isn't working?  (no bug)

layout/reftests/svg/dynamic-mask-01.svg
  timed out waiting for MozReftestInvalidate, not sure what the
  issues is (no bug)

layout/reftests/svg/dynamic-text-01.svg
layout/reftests/svg/dynamic-text-02.svg
layout/reftests/svg/dynamic-text-03.svg
layout/reftests/svg/dynamic-text-04.svg
layout/reftests/svg/dynamic-text-07.svg
layout/reftests/svg/dynamic-text-08.svg
layout/reftests/svg/dynamic-textPath-01.svg
layout/reftests/svg/gradient-live-01a.svg
layout/reftests/svg/gradient-live-01b.svg
layout/reftests/svg/gradient-live-01c.svg
layout/reftests/svg/paint-order-02.svg
layout/reftests/svg/stroke-dasharray-and-text-01.svg
layout/reftests/svg/text-gradient-02.svg
layout/reftests/svg/text-in-link-03.svg
layout/reftests/svg/text-layout-01.svg
layout/reftests/svg/text-layout-02.svg
layout/reftests/svg/text-layout-03.svg
layout/reftests/svg/text-layout-04.svg
layout/reftests/svg/text-layout-06.svg
layout/reftests/svg/text-layout-07.svg
layout/reftests/svg/text-scale-01.svg
layout/reftests/svg/textPath-01.svg
  text size wrong, might be related to mFontSizeScaleFactor?  (no bug)

layout/reftests/svg/fallback-color-02a.svg
layout/reftests/svg/fallback-color-02b.svg
layout/reftests/svg/fallback-color-04.svg
  something with a failing paint server reference and fallback color
  (no bug)

layout/reftests/svg/foreignObject-change-transform-01.svg
layout/reftests/svg/g-transform-01.svg
  maybe an issue with transform="" attribute updating not causing
  a restyle?  (no bug)

layout/reftests/svg/stroke-dasharray-02.svg
  maybe an issue with stroke-width glue, or accuracy?  (no bug)
Flags: needinfo?(cam)
Split out SVG document handling to bug 1359343, and leaving this bug to encompass remaining document types.
Assignee: cam → nobody
No longer depends on: 1359343
Priority: P1 → --
See Also: → 1363640
Priority: -- → P2
Priority: P2 → --
Priority: -- → P3
I think we've enabled stylo for everything other than xul and about: pages? Should we close this now?
(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #8)
> I think we've enabled stylo for everything other than xul and about: pages?
> Should we close this now?

Yep.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1370508
You need to log in before you can comment on or make changes to this bug.