Replace window drag space above tabs with space at the start of the tab strip

VERIFIED FIXED in Firefox 55

Status

()

defect
P1
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
Firefox 55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 verified)

Details

(Whiteboard: [photon-visual][p2][57])

Attachments

(2 attachments, 1 obsolete attachment)

Assignee

Updated

2 years ago
Duplicate of this bug: 1173731
Assignee

Updated

2 years ago
Blocks: 1185482
Assignee

Updated

2 years ago
Blocks: photon-tabs
No longer blocks: photon-visual
Flags: qe-verify+
QA Contact: ovidiu.boca
Assignee

Updated

2 years ago
Whiteboard: [photon-visual][57] → [photon-visual][p2][57]
QA Contact: ovidiu.boca → brindusa.tot
Assignee

Updated

2 years ago
No longer depends on: 1173732
Assignee

Comment 2

2 years ago
Posted patch WIP patch (obsolete) — Splinter Review
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Assignee

Updated

2 years ago
Depends on: 1363358
Iteration: --- → 55.5 - May 15
Priority: P2 → P1
Iteration: 55.5 - May 15 → 55.6 - May 29
Iteration: 55.6 - May 29 → 55.7 - Jun 12
Assignee

Updated

2 years ago
No longer depends on: 1355395
Assignee

Updated

2 years ago
Attachment #8865970 - Attachment is obsolete: true
Assignee

Updated

2 years ago
Assignee

Updated

2 years ago
OS: Windows → All

Comment 4

2 years ago
mozreview-review
Comment on attachment 8872935 [details]
Bug 1355764 - Replace window drag space above tabs with space at the start of the tab strip.

https://reviewboard.mozilla.org/r/144478/#review148362

Looks mostly good, one small issue:

This variable on OSX is still based on the previous spacing: https://searchfox.org/mozilla-central/source/browser/themes/osx/browser.css#9

That makes the buttonbox on OSX look a bit off. Weirdly, it's only used once in the tree: https://searchfox.org/mozilla-central/search?q=windowButtonMarginTop&path=

So I'd suggest removing it and setting the margin-top to 6px, same as compact theme: https://searchfox.org/mozilla-central/source/browser/themes/osx/compacttheme.css#32
Attachment #8872935 - Flags: review?(jhofmann)
Comment hidden (mozreview-request)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8872935 [details]
Bug 1355764 - Replace window drag space above tabs with space at the start of the tab strip.

https://reviewboard.mozilla.org/r/144478/#review148374

Thanks!
Attachment #8872935 - Flags: review?(jhofmann) → review+

Comment 7

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a894530a99b
Replace window drag space above tabs with space at the start of the tab strip. r=johannh
Assignee

Comment 9

2 years ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #8)
> Backed out for causing Win7 browser_roundedWindow_newWindow.js failures.
> https://hg.mozilla.org/integration/autoland/rev/
> 7fb3d9dfa8e684d5258a3d96b7176a1fa95fe205
> 
> https://treeherder.mozilla.org/logviewer.html#?job_id=103502703&repo=autoland

This appears to be a bug in calcMaximumAvailSize: http://searchfox.org/mozilla-central/rev/1a0d9545b9805f50a70de703a3c04fc0d22e3839/browser/components/resistfingerprinting/test/browser/head.js#10
It calculates the chrome dimensions in a maximized window, and then tests use them to measure non-maximized windows.
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 13

2 years ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/215cfdee973f
Replace window drag space above tabs with space at the start of the tab strip. r=johannh

Comment 14

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/215cfdee973f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Screenshots:

https://screenshots.mattn.ca/compare/?oldProject=mozilla-central&oldRev=edffa38ec0c515198f360f23d286290cb5081996&newProject=mozilla-central&newRev=cac2fd43de81d44b36396704220996b0c4a39f1a

Unfortunately a bit incomplete and full of other changes, but you can see the drag space on Windows 7 and lack of drag space on Linux (which is intended I think).

Updated

2 years ago
Depends on: 1369715
Assignee

Updated

2 years ago
Depends on: 1369786
Assignee

Updated

2 years ago
No longer depends on: 1369715

Comment 16

2 years ago
Any option to disable this? Maximized window looks goofy now :-/
Assignee

Comment 17

2 years ago
(In reply to Geobert Quach from comment #16)
> Any option to disable this? Maximized window looks goofy now :-/

That's bug 1369786.

Updated

2 years ago
Depends on: 1370205

Updated

2 years ago
No longer depends on: 1370205

Updated

2 years ago
Depends on: 1369949

Updated

2 years ago
Depends on: 1370425
Assignee

Updated

2 years ago
Depends on: 1370112
Posted image UbuntuDragSpace.jpg
Verified as fixed on latest Nightly 55.0a1 build ID 20170609030207, on Windows 10 x64 and Mac 10.12. 

For Ubuntu, as I see in the mockups (https://people-mozilla.org/~shorlander/projects/photon/Mockups/linux.html) there is no space for dragging the window.  I verified on Ubuntu 16.04 and I could not observe any space at the start of the tabs strip for window dragging(please see attachment).Is this intentional for Ubuntu OS-es?
Flags: needinfo?(dao+bmo)
Assignee

Comment 19

2 years ago
Yes, this is expected.
Flags: needinfo?(dao+bmo)
Based on comments 18 and 19, mark bug verified-fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Updated

2 years ago
Depends on: 1371306

Updated

2 years ago
Depends on: 1371769
Assignee

Updated

2 years ago
No longer blocks: 1349552
Assignee

Updated

2 years ago
No longer depends on: 1371769
Depends on: 1450741
You need to log in before you can comment on or make changes to this bug.