Message filter "Match any of…" option not working?

RESOLVED DUPLICATE of bug 1312172

Status

Thunderbird
Filters
RESOLVED DUPLICATE of bug 1312172
8 months ago
2 months ago

People

(Reporter: Kim Spence-Jones, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [filterfails])

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.97 Safari/537.36

Steps to reproduce:

I have a filter which deletes messages. It's set to "Match any of…" with a number of lines. The first line is
  From — ends with — .top
This does not match on a message it should match with. However, a filter with just this line does match, whether set to 'match all' or 'match any'. 

Setup: IMAP inbox. Ubuntu 16.04 32-bit on i7 (don't ask! lol). Thunderbird 45.7.0

Happy to provide any extra info you need.


Actual results:

Message not deleted


Expected results:

Message moved to deleted folder.
(Reporter)

Comment 1

8 months ago
p.s. The results are the same whether run automatically or manually on the message/folder
(Reporter)

Comment 2

8 months ago
p.p.s. Possible contributing factors:
My inbox is massive (18,000+ messages)
At some point filter got set to "all of…", then today set back to "Any of…"

Comment 3

8 months ago
So you said IMAP. Any condition based on the body of the e-mail?

Updated

8 months ago
Component: Untriaged → Filters

Comment 4

8 months ago
Can you check the msgFilterRules.dat file in your Thundebird profile/ImapMail/server/ folder (via file manager) oopen it in a text viewer, find that particular filter and check if the "condition=" line contains all operators being "OR" and none of them is "AND" ?

Comment 5

2 months ago
User failed to respond, but this is probably a duplicate of bug 1312172
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Whiteboard: [filterfails]
Duplicate of bug: 1312172
You need to log in before you can comment on or make changes to this bug.