Mozilla 0.9.9 - Message Filters are lost after crash

RESOLVED INVALID

Status

Core Graveyard
File Handling
--
major
RESOLVED INVALID
16 years ago
a year ago

People

(Reporter: Tilo Sloboda, Assigned: Bill Law)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I lost the Message Filters twice so far after Mozilla crashed.. sigh!



not sure which component to assign this to..
(Reporter)

Comment 1

16 years ago
It happened AGAIN!! aargh!  

Loosing the mailfilters is *REALLY* painful - could someone please add 
an "import mailfilters" option in the Preferences??  that would make life
much easier!!

Here's what happened:

  1) mozilla froze when i tried to navigate in my email. 
     it made the X-server use all CPU resources and i couldn't even 
     select *any* windows anymore   -- the window manager wasn't getting 
     any CPU cycles.   I had to kill mozilla from a remote shell.

  2) after restarting mozilla, the mailfilters were gone. 

  3) I checked in the old location

       ~/.mozilla/ts134341/sk5scb8j.slt/ImapMail/gopostal.red.iplanet.com/

     and to my surprise the rules.dat file was there and looked just *FINE*!!!
           
  4) i then created some bogus mail filters (named BLABLA) , did exit mozilla, 
     started it again and *surprise* the bogus mail filters were still there, 
     but the original rules.dat file was *unchanged*!! :-O  
     where were they stored?? 

  5) I recursively grepped for "BLABLA" in all files in the ~/.mozilla directory
     but there were no matches. 

  6) accidentially found the directory:

       ~/mail.server.server1.realhostname/

     PLEASE NOTE that this directory is created in the users's homedirectory!
     and for some reason it looks like a symbolic name which didn't got
     subsituted correctly by the real host name..  some bug there too?? 

  7) in the new  ~/mail.server.server1.realhostname/  directory, there was 
     a rules.dat file with my bogus mail filters.. 

  8) to my complete surprise, the ~/.mozilla/appreg file still contained only 
     a reference to the original location 
          /u/ts134341/.mozilla/ts134341/sk5scb8j.slt/
     and *NOT* to the newly generated directory!! ??? 


SUMMARY: 
========
    after a fatal crash, mozilla abandons the original Imap directory

       ~/.mozilla/ts134341/sk5scb8j.slt/ImapMail/gopostal.red.iplanet.com/

    and creates a new directory under the user's homedirectory, called:

       ~/mail.server.server1.realhostname/

    THIS IS SOOO ANNOYING!  Could someone please look into this? 


QUESTIONS: 

    Q1: why is this directory created outside of ~/.mozilla ??? 
        *NOTHING* should be created outside of ~/.mozilla!!!!!! 
        please don't clutter the user's homedirectory!!!!!

    Q2: why is there no option in the preferences, to load a mailfilter 
        from file? 


NOT DIRECTLY RELATED QUESTION: 

    Q3: why is the ~/.mozilla/appreg file a *BINARY* file?? 


    


     
Severity: normal → major
Keywords: mail4
(Reporter)

Comment 2

16 years ago
at another occasion, the directory created after the crash, was named: 

       ~/mail.identity.id2.drafts_folder_picker_mode/


uhm.. can you reproduce this on a recent build as 1.1beta?
QA Contact: sairuh → petersen

Comment 4

15 years ago
No response from the reporter to comment #3. Tilo, if you can reproduce this
with a current version of mozilla, please feel free to reopen this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.