Ctrl-Spacebar does not remove text formatting any more

RESOLVED DUPLICATE of bug 1346499

Status

defect
--
major
RESOLVED DUPLICATE of bug 1346499
2 years ago
2 years ago

People

(Reporter: christof, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

- Write some text using different font-families, font-sizes, font-styles, ... 
- Highlight the text
- Press [Ctrl+Spacebar]


Actual results:

The highlighted text is deleted


Expected results:

[Ctrl+Spacebar] should remove formatting of the highlighted text and reset it to the defaults. By the way: same function as in Microsoft Word, Powerpoint, and Outlook). This was working with Thunderbird versions before 52.
Reporter

Updated

2 years ago
Severity: normal → major
Summary: Ctrl-Spacebar does not work any more → Ctrl-Spacebar does not remove text formatting any more

Comment 1

2 years ago
Interesting, I didn't even know this feature. I tried the current Daily developer version TB 55 and there is works, but in TB 52 it doesn't work.

Alice, can you do a bit of research on this, please. I have a TB 54 Earlybird and there it works, too, equally in TB 45. So did something break in M-C that got fixed later?
Flags: needinfo?(alice0775)

Comment 3

2 years ago
Alice, many thanks as always!

It looks like it got fixed in
Masayuki Nakano — Bug 1346499 Don't remove Ctrl nor Alt modifier state at dispatching eKeyPress event when the modifier doesn't change inputting character. Let's ask for uplift to Mozilla ESR52.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346499
You need to log in before you can comment on or make changes to this bug.