Cannot drag and drop bookmark from maximized browser to other window

VERIFIED DUPLICATE of bug 38646

Status

()

Core
Drag and Drop
--
minor
VERIFIED DUPLICATE of bug 38646
16 years ago
16 years ago

People

(Reporter: Damian Yerrick, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.9+) Gecko/20020401
BuildID:    2002040103

When I maximize the Mozilla browser, I can't drag the bookmark icon
from the URL bar to an Explorer folder window to create a .url file.

Reproducible: Always
Steps to Reproduce:
1. Maximize Mozilla Navigator.
2. Bring an Explorer folder window to the front.
3. Try to drag the bookmark from the URL bar to the folder window.

Actual Results:  Mozilla raises itself on mouse-down,
obscuring the folder window.

Expected Results:  Mozilla is not raised until mouse-up, allowing me
to move the mouse pointer on top of the folder window and release
the mouse button to drop the bookmark.

Workaround: Restore (un-maximize) the browser window.

This may be one symptom of a more general problem with Mozilla's
drag and drop support.  Not only is it annoying for users who
habitually browse maximized, but it's also inconsistent with the
rest of Windows.  For instance, Windows Explorer on Windows ME
doesn't raise until mouse-up.
Sorry but this is the correct and usual behaviour for a maximized window, try
with IE and you'll have the same result both in Win98 and WinXP. Bug should be
marked as INVALID
(Reporter)

Comment 2

16 years ago
That's funny:  The behavior of Windows Explorer and Internet Explorer
differ under Windows 2000.  Explorer raises on mouse-up when dragging
files but on mouse-down when dragging HTML links.

Which behavior is more useful?

Comment 3

16 years ago
Easy workaround:

Drag the bookmark to the button for the folder on the taskbar. Windows will then
maximise that folder. You can then drop it onto the window.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 38646 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.