Invalid sed script generated by icu.m4

RESOLVED DUPLICATE of bug 1329272

Status

()

Firefox
Activity Streams: General
RESOLVED DUPLICATE of bug 1329272
4 months ago
4 months ago

People

(Reporter: Andrew Young, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.54 Safari/537.36

Steps to reproduce:

run:
cd js/src
./configure


Actual results:

checking for posix_fallocate... (cached) yes
sed: character class syntax is [[:space:]], not [:space:]
configure: error: cannot determine icu version number from uvernum.h header file 
DEBUG: <truncated - see config.log for full output>
DEBUG: configure:7770: checking for __thread keyword for TLS variables
DEBUG: configure:7820: checking for __attribute__((always_inline))
DEBUG: configure:7856: checking for LC_MESSAGES
DEBUG: configure:7894: checking for localeconv
DEBUG: configure:8066: checking NSPR selection
DEBUG: configure:8391: checking for gzread in -lz
DEBUG: configure:8445: /usr/lib/ccache/bin/gcc -std=gnu99 -c  -fno-math-errno -pthread  conftest.c 1>&5
DEBUG: configure:9243: checking for __cxa_demangle
DEBUG: configure:9339: checking for -pipe support
DEBUG: configure:9353: checking whether C compiler supports -fprofile-generate
DEBUG: configure:9362: /usr/lib/ccache/bin/gcc -std=gnu99 -c  -fno-math-errno -pthread -pipe -fprofile-generate -fprofile-correction  conftest.c 1>&5
DEBUG: configure:9397: checking for tm_zone tm_gmtoff in struct tm
DEBUG: configure:9451: checking what kind of list files are supported by the linker
DEBUG: configure:9456: /usr/lib/ccache/bin/gcc -std=gnu99 -o conftest.o -c  -fno-math-errno -pthread -pipe  conftest.c 1>&5
DEBUG: configure:9458: /usr/lib/ccache/bin/gcc -std=gnu99 -o conftest -lpthread  -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B /home/aryoung/wsp/gecko-dev/js/src/build/unix/gold conftest.list -lm -ldl  1>&5
DEBUG: configure:9484: checking what kind of ordering can be done with the linker
DEBUG: configure:9499: /usr/lib/ccache/bin/gcc -std=gnu99 -o conftest  -fno-math-errno -pthread -pipe  -lpthread  -Wl,-z,noexecstack -Wl,-z,text -Wl,--build-id -B /home/aryoung/wsp/gecko-dev/js/src/build/unix/gold -Wl,--section-ordering-file,conftest.order conftest.c -lm -ldl  1>&5
DEBUG: configure:9782: checking for posix_fadvise
DEBUG: configure:9782: checking for posix_fallocate
DEBUG: configure: error: cannot determine icu version number from uvernum.h header file
ERROR: old-configure failed



Expected results:

checking for posix_fallocate... (cached) yes
checking for malloc.h... (cached) yes
(Reporter)

Comment 1

4 months ago
The problem was found in the repository https://github.com/mozilla/gecko-dev on the master branch.  I'm not sure what the development branch is, so this may have already been fixed.


Linux aryoung-tp 4.10.6-1-ARCH #1 SMP PREEMPT Mon Mar 27 08:28:22 CEST 2017 x86_64 GNU/Linux

sed (GNU sed) 4.4
Copyright (C) 2017 Free Software Foundation, Inc.


At some point, sed stopped accepting the usage of `[:space:]` and only accepts `[[:space:]]`.  In icu.m4, line 72, the usage of `[ ]` is not properly escaped for m4 script.

version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9    ][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`

produces:

version=`sed -n 's/^[:space:]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
(Reporter)

Comment 2

4 months ago
I see it has been fixed by:
ebcbf47a83e7 Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
Daniel Stenberg <daniel@haxx.se>
parents: 322712
diff changeset
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329272
You need to log in before you can comment on or make changes to this bug.