https://doc.servo.org/webrender/ hangs the main thread

RESOLVED DUPLICATE of bug 1145297

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 1145297
8 months ago
7 months ago

People

(Reporter: mconley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qf:investigate:p1])

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:55.0) Gecko/20100101 Firefox/55.0 (20170412030252)

STR:

1) Visit https://doc.servo.org/webrender/

ER:

The page should render fine and the main thread in the content process shouldn't be blocked.

AR:

I get the "a page might be slowing down your browser" notification warning because the page is running JavaScript like crazy.

Here's a profile: https://perfht.ml/2p8kFql

We seem to be doing a lot of work inside search-index.js, doing some JIT stuff. Unsure if this is the right component, but thought I'd start somewhere.

Strangely, this doesn't seem to affect either Safari or Chrome.
Whiteboard: [qf] → [qf:investigate:p1]

Comment 1

8 months ago
This happens with the profiler turned on.
This is our old friend js::PCToLineNumber. We call it on the sampler thread we've paused the main thread, and it's taking a very long time, probably because it's doing a linear search on a single line of minified JavaScript. Then we unpause the main thread, realize we should be taking another sample, and pause it again.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1145297
You need to log in before you can comment on or make changes to this bug.