overflow:hidden breaks iframe resizing

RESOLVED FIXED

Status

()

Core
Layout
--
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Paul, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Clicking on 'toggle' causes the 100% iframe to become less than 100% (more like
default width). Resizing the browser causes it to go back to 100%. This only
happens with style=overflow:hidden and only with the latest mozilla builds (.99
didn't have this problem). It looks like this but may have been introduced when
overflow:hidden was fixed.

I only tested under linux but the problem likely exists elsewhere.

<html> <head>
<script language=Javascript1.2><!--
var state = 0;
function tog() {
  var f1 = document.getElementById('f1');
  if (state == 0) {
    f1.style.height='20%';
    state = 1;
  } else {
    f1.style.height='50%';
    state = 0;
  }
}
-->
</script>
</head><body style="overflow:hidden">
<a href="javascript:tog()">toggle</a>
<br><br>
<iframe style=width:100%;height:50%;border:2
        id=f1 src=http://www.google.com/></iframe>
</body>
</html>
this is a duplicate of the scrolling=no issues that were recently fixed (it's
broken in a build from a week ago and fixed in a current trunk build).
Assignee: attinasi → jkeiser
Status: UNCONFIRMED → NEW
Depends on: 119849
Ever confirmed: true
(Assignee)

Comment 2

16 years ago
fixed with bug 119849, yes.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.