Closed Bug 1356123 Opened 3 years ago Closed 3 years ago

build-docker-image-lint builds are busted

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox-esr52 fixed, firefox53 fixed, firefox54 fixed, firefox55 fixed)

RESOLVED FIXED
mozilla55
Tracking Status
firefox-esr52 --- fixed
firefox53 --- fixed
firefox54 --- fixed
firefox55 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(1 file)

While modifying various things under taskcluster/ for bug 1355731, triggering some docker image jobs, I got the following error:

  # Without this we get spurious "LC_ALL: cannot change locale (en_US.UTF-8)" errors,
  # and python scripts raise UnicodeEncodeError when trying to print unicode characters.
  locale-gen en_US.UTF-8
  /tmp/system-setup.sh: line 25: locale-gen: command not found
  The command [/bin/sh -c bash /tmp/system-setup.sh] returned a non-zero code: 127
Comment on attachment 8857775 [details]
Bug 1356123 - Add missing locales package to the lint docker image.

https://reviewboard.mozilla.org/r/129744/#review132372

RyanVM encountered this bustage on beta or esr52 after an uplift today. The image built just fine ~24 hours ago. I think the underlying problem is a change in upstream packaging coupled with non-determinism in the image build process (`apt-get update` fetches the latest package database which varies over time). Since *something* in apt land is broken because of this missing file, I wouldn't be surprised if upstream reverts that change in the next day or two. It has happened before.
Attachment #8857775 - Flags: review+
Comment on attachment 8857775 [details]
Bug 1356123 - Add missing locales package to the lint docker image.

https://reviewboard.mozilla.org/r/129744/#review132372

Oh, we were calling locale-gen directly. I guess we relied on it being brought in by a dependency that no longer exists. Kudos to upstream for pruning an excessive dependency then :)
Attachment #8857775 - Flags: review?(dustin)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/705ab99fffa0
Add missing locales package to the lint docker image. r=gps
Moving to Core::Build Config to be able to request approval for other trees...
Component: Docker Images → Build Config
Product: Taskcluster → Core
Comment on attachment 8857775 [details]
Bug 1356123 - Add missing locales package to the lint docker image.

Approval Request Comment
[Feature/Bug causing the regression]: Some upstream Ubuntu change
[User impact if declined]: build-docker-image-lint bustage
[Is this code covered by automated tests?]: The job is either busted or not, so in some sense, the code is covered.
[Has the fix been verified in Nightly?]: The job was green on autoland.
[Needs manual test from QE? If yes, steps to reproduce]: N/A
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only adds a package to install when building the docker image, a package that used to be there automatically but somehow isn't anymore.
[String changes made/needed]: N/A

All branches are affected except esr45.
Attachment #8857775 - Flags: approval-mozilla-release?
Attachment #8857775 - Flags: approval-mozilla-esr52?
Attachment #8857775 - Flags: approval-mozilla-beta?
Attachment #8857775 - Flags: approval-mozilla-aurora?
Note that the file to patch on esr52 is testing/docker/lint/system-setup.sh. The location changed during the 53 cycle, which makes the landed patch valid for all branches except esr52 (since release is now on 53).
Comment on attachment 8857775 [details]
Bug 1356123 - Add missing locales package to the lint docker image.

Gonna land this a=NPOTB
Attachment #8857775 - Flags: approval-mozilla-release?
Attachment #8857775 - Flags: approval-mozilla-esr52?
Attachment #8857775 - Flags: approval-mozilla-beta?
Attachment #8857775 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/705ab99fffa0
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.