wikipedia FR can't be added to the list of search engines from the search toolbar

RESOLVED DUPLICATE of bug 1352161

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1352161
8 months ago
8 months ago

People

(Reporter: karlcow, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 months ago
This is a spin-off of https://webcompat.com/issues/5612

Steps to Reproduce

    Navigate to: https://fr.wikipedia.org/wiki/Wikipédia:Accueil_principal
    Click on the lens icon of the search bar
    Click on "Add Wikipédia (fr)"

Expected Behavior:

Wikipédia (fr) should get added to the search bar engines list

Actual Behavior:

Wikipédia (fr) does not get into the search bar engines list. It evens messes with my actual Firefox (standard release) search engines list.
It doesn't work in Nightly for me either

ASSERT: *** Search: Engine location is neither a File nor a URI object
  debug.js:54
NS_ERROR_FAILURE: addEngine: Error adding engine:
[Exception... "Engine location is neither a File nor a URI object"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: jar:file:///Applications/FirefoxNightly.app/Contents/Resources/omni.ja!/components/nsSearchService.js :: ERROR :: line 255"  data: no]  nsSearchService.js:268
I think there might be two issues here. The first is not being able to add a search engine - that's bug 1352161.

The second could be something to do with "It evens messes with my actual Firefox (standard release) search engines list."

I don't see that when I try it here locally.

Eric, I think you might be the original reporter, can you add a screenshot of how it messes with the list?

Could you also test it in 53, since that's where bug 1113747 landed?
Depends on: 1352161
Flags: needinfo?(etsai)

Comment 3

8 months ago
:standard8 , it's from anonymous reporter. In Firefox 53 it's fixed.
I guess the second issue means the user shares the same profile using Firefox release and Firefox Nightly, that breaks search engine list?
Flags: needinfo?(etsai)
Thanks Eric.

I can't see any obvious route the search engine list would be broken with this, so I'll assume the main issue is bug 1352161 and keep an eye out for anything about the search bar itself.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1352161
You need to log in before you can comment on or make changes to this bug.