Closed Bug 1356154 Opened 6 years ago Closed 6 years ago

Since bug 1337743 landed, quitApplication no longer supports callbacks (eg. click on restart button)

Categories

(Testing :: Marionette, defect)

Version 3
defect
Not set
major

Tracking

(firefox53 unaffected, firefox54 affected, firefox55 affected)

RESOLVED INVALID
Tracking Status
firefox53 --- unaffected
firefox54 --- affected
firefox55 --- affected

People

(Reporter: whimboo, Unassigned)

References

Details

(Keywords: regression)

This is a serious regression from the patches on bug 1337743 which stopped our tests from specifying a custom shutdown/restart method via a callback like a click on the restart button. Instead Marionette now always calls `Services.startup.quit()`.

Andreas, can you please have a look at it? Thanks.
Flags: needinfo?(ato)
Summary: quitApplication no longer supports callbacks (eg. click on restart button) → Since bug 1337743 landed, quitApplication no longer supports callbacks (eg. click on restart button)
I don’t exactly understand what is wrong.  As far as I can tell, _request_in_app_shutdown does not take a callback: http://searchfox.org/mozilla-central/source/testing/marionette/client/marionette_driver/marionette.py#1133.  I see that quit does, in http://searchfox.org/mozilla-central/source/testing/marionette/client/marionette_driver/marionette.py#1189, but it only invokes _request_in_app_shutdown when the callback isn’t callable.

Do you have a link to a stacktrace or a paste of an exception?
Flags: needinfo?(ato)
Oh, you are right. Looks like I was too fast in blaming this change, when I have seen issues with the patch on bug 1304656. I will have to take a closer look again today.
Severity: normal → major
Flags: needinfo?(hskupin)
Ok, I can clearly see that `quitApplication` is used in all the cases when update tests are restarting Firefox. But at the same time it doesn't seem to be an issue with Marionette, because `restart()` gets `callback=None`. So the flaw lays somewhere in the Puppeteer, or Firefox UI harness code.

I'm going to close this bug, and continue to figure this out on bug 1304656. Sorry for the noise.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(hskupin)
Resolution: --- → INVALID
No longer blocks: 1298803
You need to log in before you can comment on or make changes to this bug.