Closed Bug 1356294 Opened 4 years ago Closed 3 years ago

Remove no longer updated languages from SeaMonkey

Categories

(SeaMonkey :: Build Config, enhancement)

enhancement
Not set
normal

Tracking

(seamonkey2.48 fixed, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 fixed, seamonkey2.52 fixed)

RESOLVED FIXED
seamonkey2.52
Tracking Status
seamonkey2.48 --- fixed
seamonkey2.49esr --- fixed
seamonkey2.50 --- wontfix
seamonkey2.51 --- fixed
seamonkey2.52 --- fixed

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file, 1 obsolete file)

Looking at the current l10n dashboards the following languages seem to be no longer updated for SeaMonkey string changes and so language packs and installers should no longer be build for release:

ca
fi
gl  See also Bug 1218107 
lt
nb-NO
tr
uk


en-GB cointains a lot of untranslated strings too but I suspect using the en-US ones is fine here :)
Added known localization staff from <https://wiki.mozilla.org/SeaMonkey:Localization_Teams>
we'll need to contact all those locales' members and ask whether they're still interested
in localizing SeaMonkey.
Attached patch 1356294-obsoletel10n.patch (obsolete) — Splinter Review
lt still shows activity. All the other are dead as far as it concerns suite :(
Attachment #8867528 - Flags: review?(iann_bugzilla)
Comment on attachment 8867528 [details] [diff] [review]
1356294-obsoletel10n.patch

I'd definitely removed gl from both, then rest from just shipped-locales
r=me with that change.
Attachment #8867528 - Flags: review?(iann_bugzilla) → review+
Issues addresed r+ from IanN retained and pushed 
https://hg.mozilla.org/comm-central/rev/fe87ba2b4e5b4d64822ae23abfb64f9031819dc1

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: only partially translated releases are shipped.
Testing completed (on m-c, etc.): c-c 
Risk to taking this patch (and alternatives if risky): none 
String changes made by this patch: none but removes some languages.

c-r approval is meant for 2.48.
Assignee: nobody → frgrahl
Attachment #8867528 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8874249 - Flags: review+
Attachment #8874249 - Flags: approval-comm-release?
Attachment #8874249 - Flags: approval-comm-esr52?
Attachment #8874249 - Flags: approval-comm-beta?
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.52
Version: unspecified → Trunk
Comment on attachment 8874249 [details] [diff] [review]
1356294-obsoletel10n-V2.patch

a=me for requested repos
Attachment #8874249 - Flags: approval-comm-release?
Attachment #8874249 - Flags: approval-comm-release+
Attachment #8874249 - Flags: approval-comm-esr52?
Attachment #8874249 - Flags: approval-comm-esr52+
Attachment #8874249 - Flags: approval-comm-beta?
Attachment #8874249 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.