Closed Bug 1356382 Opened 3 years ago Closed 3 years ago

"USE_LIBS contains 'jsoncpp', which does not match any LIBRARY_NAME in the tree." with --disable-crashreporter

Categories

(Core :: WebVR, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla55
Tracking Status
firefox55 --- fixed

People

(Reporter: RyanVM, Assigned: kip)

References

Details

Attachments

(1 file)

mozbuild.frontend.reader.SandboxValidationError:
==============================
ERROR PROCESSING MOZBUILD FILE
==============================

The error occurred while processing the following file or one of the files it includes:
 0:36.51
    c:/Users/Ryan/repos/mozilla/gfx/vr/openvr/moz.build
 0:36.51
The error occurred when validating the result of the execution. The reported error is:
 0:36.51
    USE_LIBS contains "jsoncpp", which does not match any LIBRARY_NAME in the tree.

AFAICT, jsoncpp lives inside the crashreporter directory.
Code in the gfx/vr/openvr directory is intended to use the same "jsoncpp" library that already exists in the crashreporter directory.

Perhaps the USE_LIBS entry was superfluous and can just be dropped?

Please advise if there are other steps I may be missing here.
Flags: needinfo?(ryanvm)
I just noticed the "with --disable-crashreporter" in the description.

Perhaps we could move jsoncpp somewhere that better represents that it should be enabled with or without crashreporter.

If this would be acceptable, I could make a patch to that effect.

Thanks again!
Moving the code elsewhere was what I was thinking too. Ted, do you see a problem with moving jsoncpp out of the crashreporter directory to somewhere else within toolkit? Maybe toolkit/components instead?
Flags: needinfo?(ryanvm) → needinfo?(ted)
Assignee: nobody → kgilbert
Feel free to move it wherever. It was put under toolkit/crashreporter because that was the only thing using it at the time.
Flags: needinfo?(ted)
I've found the cause of the static analysis failures in the try push...

The isIgnoredPathForSprintfLiteral function in clang-plugin/Utils.h is ignoring the "crashreporter" directory:

Begin->compare_lower(StringRef("crashreporter")) == 0 ||

When the json library was moved out of this directory, the exclusion was no longer applied.

I will try re-submitting the try push with the directory changed to match just jsoncpp and see if it passes.
(In reply to :kip (Kearwood Gilbert) from comment #7)
> I've found the cause of the static analysis failures in the try push...
> 
> The isIgnoredPathForSprintfLiteral function in clang-plugin/Utils.h is
> ignoring the "crashreporter" directory:
> 
> Begin->compare_lower(StringRef("crashreporter")) == 0 ||
> 
> When the json library was moved out of this directory, the exclusion was no
> longer applied.
> 
> I will try re-submitting the try push with the directory changed to match
> just jsoncpp and see if it passes.

It appears that the "crashreporter" directory is also required in the exception.

Hopefully this latest try push is good now
Attachment #8858164 - Flags: review?(ted)
Comment on attachment 8858164 [details]
Bug 1356382 - Move jsoncpp library and ensure it is included even when crashreporter is not

https://reviewboard.mozilla.org/r/130110/#review135366
Attachment #8858164 - Flags: review?(ted) → review+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bf2654d9c375
Move jsoncpp library and ensure it is included even when crashreporter is not r=ted
https://hg.mozilla.org/mozilla-central/rev/bf2654d9c375
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
I noticed that update-jsoncpp.sh is still under toolkit/crashreporter/. I guess it should be moved to the new location as well?
Flags: needinfo?(kgilbert)
Depends on: 1371839
See Also: → 1379704
I have filed Bug 1379704 to cover the updating and moving of update-jsoncpp.sh
Flags: needinfo?(kgilbert)
You need to log in before you can comment on or make changes to this bug.