Intermittent test_ext_proxy.html | message queue is empty - got "[\"proxy-error-received\"]", expected "[]"

RESOLVED FIXED in Firefox 55

Status

WebExtensions
General
RESOLVED FIXED
a year ago
6 days ago

People

(Reporter: Treeherder Bug Filer, Assigned: mattw)

Tracking

({intermittent-failure})

unspecified
mozilla55
intermittent-failure

Firefox Tracking Flags

(firefox55 fixed)

Details

(Whiteboard: [stockwell unknown])

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(2 attachments)

Comment 1

a year ago
16 failures in 894 pushes (0.018 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 7
* mozilla-inbound: 6
* mozilla-central: 3

Platform breakdown:
* linux32: 12
* windows7-32-vm: 2
* windows8-64: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356457&startday=2017-04-10&endday=2017-04-16&tree=all
:mattw - Do you want to take another look at this? It seems the previous fix was ineffective.
Flags: needinfo?(mwein)
in the last week has have 50 failures, so this is getting to be a bit more painful
Whiteboard: [stockwell needswork]

Comment 4

a year ago
15 failures in 162 pushes (0.093 failures/push) were associated with this bug yesterday.   

Repository breakdown:
* autoland: 7
* mozilla-inbound: 5
* graphics: 3

Platform breakdown:
* linux32: 13
* osx-10-10: 1
* linux64: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356457&startday=2017-04-21&endday=2017-04-21&tree=all

Comment 5

a year ago
63 failures in 817 pushes (0.077 failures/push) were associated with this bug in the last 7 days. 

This is the #9 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 25
* mozilla-inbound: 24
* try: 5
* mozilla-central: 5
* graphics: 4

Platform breakdown:
* linux32: 44
* linux64: 8
* windows7-32-vm: 7
* windows8-64: 2
* osx-10-10: 1
* android-4-3-armv7-api15: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356457&startday=2017-04-17&endday=2017-04-23&tree=all
Summary: Intermittent toolkit/components/extensions/test/mochitest/test-oop-extensions/test_ext_proxy.html | message queue is empty - got "[\"proxy-error-received\"]", expected "[]" → Intermittent test_ext_proxy.html | message queue is empty - got "[\"proxy-error-received\"]", expected "[]"
Created attachment 8862860 [details] [diff] [review]
disable test

This test was added in bug 1295807 and started failing intermittently right away - reported initially in bug 1345491, where a fix was attempted - so we are coming up on 8 weeks of flakiness. Hopefully Matt can sort out the issue in the future and get this re-enabled.
Attachment #8862860 - Flags: review?(jmaher)
Comment on attachment 8862860 [details] [diff] [review]
disable test

Review of attachment 8862860 [details] [diff] [review]:
-----------------------------------------------------------------

make sure to add leave-open here
Attachment #8862860 - Flags: review?(jmaher) → review+
Whiteboard: [stockwell needswork] → [stockwell disabled]

Comment 8

a year ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fb4dfb493bbb
Skip test_ext_proxy.html for frequent failures; r=jmaher
Keywords: leave-open
31 failures in 883 pushes (0.035 failures/push) were associated with this bug in the last 7 days. 

This is the #38 most frequent failure this week.  

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 20
* mozilla-inbound: 6
* graphics: 2
* try: 1
* oak: 1
* mozilla-central: 1

Platform breakdown:
* linux32: 16
* linux64: 11
* windows7-32-vm: 2
* osx-10-10: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1356457&startday=2017-04-24&endday=2017-04-30&tree=all
(Assignee)

Comment 11

a year ago
I was able to reproduce the intermittent locally and will now try to find a fix.
Flags: needinfo?(mwein)
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Assignee: nobody → mwein
Comment hidden (mozreview-request)

Comment 14

a year ago
mozreview-review
Comment on attachment 8863377 [details]
Bug 1356457 - Fix and enable test_ext_proxy.html

https://reviewboard.mozilla.org/r/135136/#review138088

this looks good, as a note, this test is skipped, so we need to edit the manifest to not skip it:
https://dxr.mozilla.org/mozilla-central/source/toolkit/components/extensions/test/mochitest/mochitest-common.ini#78
Attachment #8863377 - Flags: review?(jmaher) → review+
Comment hidden (mozreview-request)
(Assignee)

Comment 16

a year ago
Thanks
Keywords: leave-open → checkin-needed
This could be caused by fetching of the "favicon.ico" when you open a tab.  You should be able to confirm it by dump()ing the url from the FindProxyForURL() function.  If that's indeed the case, then this solution (or just removing the listener after the first error) should be fine.
Keywords: checkin-needed → leave-open
Sorry for the keywords, that was by accident.
Keywords: leave-open → checkin-needed

Comment 19

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3ef61ecb82e2
Fix and enable test_ext_proxy.html r=jmaher
Keywords: checkin-needed

Comment 20

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/3ef61ecb82e2
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
(Assignee)

Comment 21

a year ago
needinfo'ing myself to look into comment 18.
Flags: needinfo?(mwein)
(Assignee)

Comment 22

a year ago
sorry, I mean comment 17
Flags: needinfo?(mwein)
(Assignee)

Updated

a year ago
Flags: needinfo?(mwein)
Removing the [stockwell disabled] tag because the test that this bug references no longer exists. I changed it to [stockwell unknown] rather than just removing the tag entirely to maintain a record.
Flags: needinfo?(matthewjwein)
Whiteboard: [stockwell disabled] → [stockwell unknown]

Updated

6 days ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.