If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Regression] Firefox will crash on Top Sites after first sync on iPad

VERIFIED FIXED

Status

()

Firefox for iOS
Home screen
P1
critical
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: SimonB, Assigned: farhan)

Tracking

({crash, regression, reproducible})

unspecified
Other
iOS
crash, regression, reproducible

Firefox Tracking Flags

(fxios8.0+, fxios-v7.2 unaffected, fxios-v8.0 verified)

Details

(Whiteboard: [MobileCore])

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Created attachment 8858260 [details]
Client  14-04-2017, 11-35.crash

Build: 58b02370e25
Device: iPad Pro
iOS: 10.3

Steps to reproduce:
1. Install Firefox
2. Launch Firefox
3. Log in to FxA with sync data

Actual results: 
- Firefox will crash after first sync. 

Note:
- I am also logged in on desktop with this FxA.
(Reporter)

Comment 1

5 months ago
Regression range:

- Last good build: BuddyBuild #2396
- First bad build: BuddyBuild #2605
(Reporter)

Comment 2

5 months ago
Note: 
- I was unable to reproduce this on iPhone following the STR with the same FxA.
Summary: [Regression] Firefox will crash after first sync → [Regression] Firefox will crash after first sync on iPad
Can you reproduce this if you aren't on the home screen? The crash doesn't look anything to do with Sync.
Flags: needinfo?(simion.basca)
(Reporter)

Comment 4

5 months ago
(In reply to Richard Newman [:rnewman] from comment #3)
> Can you reproduce this if you aren't on the home screen? 

I am not reproducing this issue if I visit a page while the first sync occurs. I am reproducing this issue only on Top Sites.
Flags: needinfo?(simion.basca)
Component: Sync → Home screen
Summary: [Regression] Firefox will crash after first sync on iPad → [Regression] Firefox will crash on Top Sites after first sync on iPad
tracking-fxios: ? → 8.0+
Priority: -- → P2

Updated

5 months ago
Whiteboard: [MobileCore]
(Reporter)

Comment 5

5 months ago
Note:
- This issue is not related to a particular FxA. I manage to reproduce this issue using several test accounts.
(Assignee)

Comment 6

5 months ago
Created attachment 8860462 [details]
Pull Request
Attachment #8860462 - Flags: review?(sleroux)
Attachment #8860462 - Flags: review?(sleroux) → review+
(Assignee)

Comment 7

5 months ago
master https://github.com/mozilla-mobile/firefox-ios/commit/04aa407e19b6e0497f7e15f4bfb8a2c9e8bd61cd
Assignee: nobody → fpatel
Status: NEW → RESOLVED
Iteration: --- → 1.20
Last Resolved: 5 months ago
Priority: P2 → P1
Resolution: --- → FIXED
(Reporter)

Comment 8

4 months ago
Verifying as fix on master b3b12590beb.
Status: RESOLVED → VERIFIED
status-fxios-v8.0: affected → verified
You need to log in before you can comment on or make changes to this bug.