'Unknow' pop server response may mozilla-mail bring into an endless-loop

RESOLVED INVALID

Status

MailNews Core
Networking: POP
--
major
RESOLVED INVALID
16 years ago
9 years ago

People

(Reporter: Adrian Ulrich, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
This bug may be a bit difficult to reproduce..

I have a pop3 mailbox and i can also access this mailbox via browser under the
url webmail.webspace4you.ch .. its a product called 'VOPmail'

The problem:
1) Login with the HTML Frontend (vopmail)
2) Now try to retrive your mails via mozilla mail (same mailbox, while you are
logged in)
Mozilla recives a message that it doesn't understand and it will try again,
again, again..

here a telnet log:

ulrich@oma:~$ telnet pop3.blinkenlights.ch 110
Trying 212.80.184.4...
Connected to pop3.blinkenlights.ch.
Escape character is '^]'.
+OK VOPmail POP3 Server-NOTF 5.0.194.0 Ready <147654704.1018008047.477@genotec.ch>

user pab@blinkenlights.ch
+OK pab@blinkenlights.ch is welcome here
pass blabla
-ERR mailbox in use

..and 'mailbox in use' isn't understood by mozilla mail :)

Updated

15 years ago
QA Contact: sheelar → esther

Comment 1

15 years ago
Reporter: can you confirm this still happens on a modern build of mozilla?

Comment 2

14 years ago
> -ERR mailbox in use
> 
> ..and 'mailbox in use' isn't understood by mozilla mail :)

Of course. POP3 protcol only knows -ERR and +OK. The text after these codes is
just informative and shouldn't be parsed. To submit further informations
extended codes have been created in RFC 2449 and 3206.

The problem is, that these extended codes are not mandatory and therefore not
wide spread. A server that wants to be understood should send
-ERR [IN-USE] mailbox in use.
Mozillas newer than 2003-07-13 are aware of this code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Hardware: PC → All
Resolution: --- → INVALID
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.