print preview doesn't work without a printer - I think it should

RESOLVED DUPLICATE of bug 702678

Status

()

Core
Print Preview
--
minor
RESOLVED DUPLICATE of bug 702678
16 years ago
4 years ago

People

(Reporter: Azrael AOD, Assigned: rods (gone))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
1) Have no printers installed
2) Load a page in Mozilla
3) Print Preview
4) Curse inability to get it

Ok, now it sounds obvious, but why do you need a printer for print preview?
Wanting to print preview a page should be allowed for those without printers,
because it's not always done with the intention to print.
Unless there is any functional requirement, to possess a printer, in order for
print preview to work, then I suggest that this dependancy not be forced, and
the 'no printer' error message be left to the print buttons.

When designing pages at home (with no printer) I would like to use the print
preview button to see how it would end up being printed.. is a fix for this
problem easy, and is it worthwhile in anyone elses eyes?
(Assignee)

Comment 1

16 years ago
I understand why you want to do it, but it needs a printer to do print preview,
because it uses the printer's info to set up for PP.

You should install a printer (post script) and when you set it up instead of
printing to LPT1: etc, have it print to a file "FILE:" Then if you like, you
should get a copy of ghostview/ghostscript that can read and diplay postscript
output (it's free). I do a lot of my testing this way instead of wasting paper.
Then PrintPreview will work.

Or actually you could just install a printer and you don't have to have it
hooked up for PP to work.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 2

16 years ago
what exactly does it need from printer?

print preview on linux will work fine w/o a printer ..
(Reporter)

Comment 3

16 years ago
Point taken 'rods', and perhaps as being slightly more than a normal user, I can
work my way around this. However with Vadim's comment, that linux doesn't need a
printer installed, wouldn't it be nice to have Mozilla behave the same way in
this respect on each platform?

Comment 4

16 years ago
verified.
Status: RESOLVED → VERIFIED
*** Bug 193598 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
But why IE on the same platform does not need an installed printer? Why on Linux
it does not needs a printer?

Can we emulate some standart printer just to have a print preview without a printer?

Comment 7

16 years ago
Eugene Savitsky wrote:
> But why IE on the same platform does not need an installed printer? Why on 
> Linux it does not needs a printer?

On Linux there is always the "PostScript/default" printer so there is always a
printer present on Linux.

Comment 8

14 years ago
Even MS Office needs a printer installed to do print preview, it is not a
Mozilla only problem.

Just add any printer (a good laser one for nice previews) into Windows any you
are Ok. As said, you don't have to physically connect the printer. You just need
any printer driver, or choose from the Windows default ones.

Actually it is correct, if the preview depends on a printer. It should show how
the page will look on the specific printer and not some generic hypotetical
device. In needs to know its DPI resolution etc. And it gives vastly different
renderings with differrent printers (which may be a bug but it works this way now).

*** Bug 269732 has been marked as a duplicate of this bug. ***
*** Bug 269968 has been marked as a duplicate of this bug. ***
*** Bug 274063 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 587655

Comment 13

8 years ago
(In reply to comment #6)
> But why IE on the same platform does not need an installed printer?

This question still hasn't been answered.

(In reply to comment #8)

> Just add any printer (a good laser one for nice previews) into Windows any you
> are Ok. As said, you don't have to physically connect the printer. You just need
> any printer driver, or choose from the Windows default ones.

The user should not need to do carry out this step, Firefox should provide this as default just like IE. After being closed for 6 years I think this issue should be looked at again.
Depends on: 702678
Given that (a) this works fine on Mac and Linux (b) we need this to work on Windows for our test suite, and (c) we're 90% there in bug 702678, I'm going to convert this into a duplicate of that bug.
Status: VERIFIED → RESOLVED
Last Resolved: 16 years ago4 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 702678
You need to log in before you can comment on or make changes to this bug.