NS_ERROR_DOM_MEDIA_METADATA_ERR occurred when Seek was inserted in SeekHead so that WebM recorded by MediaRecorder could be seeked.

RESOLVED INVALID

Status

()

Core
Audio/Video
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: legokichi, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3072.0 Safari/537.36

Steps to reproduce:

I added Seek element to SeekHead element and Duration element to Info element so that WebM recorded by MediaRecorder can be seekable.
For SeekID, we specified the Cluster element and SeekPosition wrote the location of that Cluster element from the beginning of the file.
Then, I converted the converted WebM blob as blobURL and played it with Video element.

Firefox Nightly 55.0a1 64bit
MacOS Sierra 10.12.3
MacBook Pro (13-inch, Early 2011)

source: https://github.com/legokichi/ts-ebml/blob/88beee06d5dad0e36c9b082d7da2d7eb227ca3b1/src/seekable_example.ts
demo: https://jsfiddle.net/1nrx33gd/
related issue: https://github.com/legokichi/ts-ebml/issues/2
original WebM file: https://github.com/legokichi/ts-ebml/blob/f5c7633a8de2a31a4e981edea983abd5f3e9e980/test/firefox55nightly.webm
converted WebM file: https://github.com/legokichi/ts-ebml/blob/f5c7633a8de2a31a4e981edea983abd5f3e9e980/test/firefox55nightly.refined.seekhead.webm


Actual results:

cannot play video.

Media resource http://localhost:8000/test/firefox55nightly.refined.seekhead.webm could not be decoded, error: Error Code: NS_ERROR_DOM_MEDIA_METADATA_ERR (0x806e0006)


Expected results:

On Chrome 60.0.3072.0 canary (64-bit), That demo code works and seekable, but firefox not.
(Reporter)

Updated

a year ago
Summary: webm NS_ERROR_DOM_MEDIA_METADATA_ERR → NS_ERROR_DOM_MEDIA_METADATA_ERR occurred when Seek was inserted in SeekHead so that WebM recorded by MediaRecorder could be seeked.

Updated

a year ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
(Reporter)

Comment 1

a year ago
Eventually, I found out that it was my mistake. That WebM file is broken.

```
$ mkvalidator --details test/firefox55nightly.refined.seekhead.webm
...
WRN00C: Unknown element in TrackEntry [56][AA] at 265 (size 4 total 7)
WRN00C: Unknown element in TrackEntry [56][BB] at 272 (size 4 total 7)
...
```

This was due to the fact that the first Cluster element could not be successfully inserted.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.