1.8ms uninterruptible reflow at openLinkIn@chrome://browser/content/utilityOverlay.js:472:5

RESOLVED FIXED in Firefox 55

Status

()

defect
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rjward0, Unassigned)

Tracking

(Blocks 1 bug)

unspecified
Firefox 55
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ohnoreflow][qf:p2][reserve-photon-performance])

Reporter

Description

2 years ago
Here's the stack:

openLinkIn@chrome://browser/content/utilityOverlay.js:472:5
openUILinkIn@chrome://browser/content/utilityOverlay.js:194:3
BrowserOpenTab@chrome://browser/content/browser.js:2146:3
oncommand@chrome://browser/content/browser.xul:1:1
I already noted this in bug 1349211 comment 4, but that bug is confusing, so let's keep this one to study the openLinkIn case specifically.
Blocks: 1349211
Flags: qe-verify?
Priority: -- → P2
Component: Untriaged → Tabbed Browser
Depends on: 1356034
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf:p1][photon-performance]
Another stack:

openLinkIn@chrome://browser/content/utilityOverlay.js:472:5
_loadSearch@chrome://browser/content/browser.js:3916:5
loadSearchFromContext@chrome://browser/content/browser.js:3946:18
oncommand@chrome://browser/content/browser.xul:1:1
Another related stack:

openLinkIn@chrome://browser/content/utilityOverlay.js:476:5
openUILinkIn@chrome://browser/content/utilityOverlay.js:198:3
BG_observe@resource://app/components/nsBrowserGlue.js:432:13
open@chrome://global/content/bindings/text.xml:358:11
onxblclick@chrome://global/content/bindings/text.xml:377:1
Flags: qe-verify? → qe-verify-
Priority: P2 → P3
Whiteboard: [ohnoreflow][qf:p1][photon-performance] → [ohnoreflow][qf:p1][reserve-photon-performance]
Whiteboard: [ohnoreflow][qf:p1][reserve-photon-performance] → [ohnoreflow][qf:p2][reserve-photon-performance]
I can no longer reproduce a reflow in this codepath since bug 1369140 landed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Iteration: --- → 55.7 - Jun 12
Priority: P3 → P1
You need to log in before you can comment on or make changes to this bug.