Mac builds broken as of 2017-04-15 - AttributeError: 'NoneType' object has no attribute 'startswith' - Python problem

RESOLVED WORKSFORME

Status

Thunderbird
Build Config
RESOLVED WORKSFORME
10 months ago
10 months ago

People

(Reporter: Jorg K (GMT+1), Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Thunderbird-testfailure: B Mac all])

(Reporter)

Description

10 months ago
builder: comm-central-macosx64-debug
slave: bld-lion-r5-081
starttime: 1492294089.89
results: failure (2)
buildid: Please use the *system* python to run this script
Traceback (most recent call last):
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/virtualenv/virtualenv.py", line 2325, in <module>
    main()
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/virtualenv/virtualenv.py", line 711, in main
    symlink=options.symlink and hasattr(os, 'symlink')) # MOZ: Make sure we don't use symlink when we don't have it
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/virtualenv/virtualenv.py", line 924, in create_environment
    site_packages=site_packages, clear=clear, symlink=symlink))
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/objdir-tb/_virtualenv/lib/python2.7/posixpath.py", line 343, in abspath
    if not isabs(path):
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/objdir-tb/_virtualenv/lib/python2.7/posixpath.py", line 53, in isabs
    return s.startswith('/')
AttributeError: 'NoneType' object has no attribute 'startswith'
Error running mach:

    ['python', '/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/config/printconfigsetting.py', '/builds/slave/tb-c-cen-m64-d-000000000000000/build/objdir-tb/dist/bin/application.ini', 'App', 'BuildID']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: Failed to create virtualenv: /builds/slave/tb-c-cen-m64-d-000000000000000/build/objdir-tb/_virtualenv

  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/mach_commands.py", line 42, in python
    self._activate_virtualenv()
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/mozbuild/mozbuild/base.py", line 623, in _activate_virtualenv
    self.virtualenv_manager.ensure()
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/mozbuild/mozbuild/virtualenv.py", line 166, in ensure
    return self.build(python)
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/mozbuild/mozbuild/virtualenv.py", line 439, in build
    self.create(python)
  File "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/mozbuild/mozbuild/virtualenv.py", line 203, in create
    'Failed to create virtualenv: %s' % self.virtualenv_root)
builduid: 362af7bbdb034e528f3b877f7e24e051
revision: e2a93f33a9826ae2039589d25ed0ea6bde13dbf9

There are more errors in the log further down:
https://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-macosx64/1492287270/comm-central-macosx64-bm84-build1-build111.txt.gz

Anything our build experts can spot easily? Maybe a buildbot issue?

===

Last good:
M-C: 9379831bb9c3d9abfea7dbf8dd06dbdab1

First bad:
M-C: ce69b6e1773e9e0d0a190ce899f34b1658

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9379831bb9c3d9abfea7dbf8dd06dbdab1&tochange=ce69b6e1773e9e0d0a190ce899f34b1658
(Reporter)

Updated

10 months ago
Summary: MAc builds broken as of 2017-04-15 - AttributeError: 'NoneType' object has no attribute 'startswith' - Python problem → Mac builds broken as of 2017-04-15 - AttributeError: 'NoneType' object has no attribute 'startswith' - Python problem
Philipp, maybe you can help here?
Flags: needinfo?(philipp)
Maybe caused by bug 1356101. Don't think its bug 1356541.

Don't own a mac. Is local building still possible?
(Reporter)

Comment 3

10 months ago
Gregory and Mike, could you please cast an eye on this failure and give us a hint.
Flags: needinfo?(mh+mozilla)
Flags: needinfo?(gps)

Comment 4

10 months ago
(In reply to Jorg K (GMT+2) from comment #0)
> builder: comm-central-macosx64-debug
> slave: bld-lion-r5-081
> starttime: 1492294089.89
> results: failure (2)
> buildid: Please use the *system* python to run this script
> Traceback (most recent call last):
>   File
> "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/
> virtualenv/virtualenv.py", line 2325, in <module>
>     main()
>   File
> "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/
> virtualenv/virtualenv.py", line 711, in main
>     symlink=options.symlink and hasattr(os, 'symlink')) # MOZ: Make sure we
> don't use symlink when we don't have it
>   File
> "/builds/slave/tb-c-cen-m64-d-000000000000000/build/mozilla/python/
> virtualenv/virtualenv.py", line 924, in create_environment
>     site_packages=site_packages, clear=clear, symlink=symlink))

That code reads:

    py_executable = os.path.abspath(install_python(
        home_dir, lib_dir, inc_dir, bin_dir,
        site_packages=site_packages, clear=clear, symlink=symlink))

You need to figure out why install_python is returning None in your case.
Flags: needinfo?(mh+mozilla)

Comment 5

10 months ago
What glandium said.
Flags: needinfo?(gps)
(Reporter)

Comment 6

10 months ago
This is intermittent, would you believe.

Failed: Mon Apr 17, 0:15:06, both opt and debug
Worked: Mon Apr 17, 18:04:06, both opt and debug
Failed: Mon Apr 17, 22:39:06, in fact, opt failed, debug worked.

Comment 7

10 months ago
I'm guessing it is intermittent due to file reuse from a previous job. There's probably a symlink pointing to a now-removed directory (perhaps a per-job temporary directory) or something like that.
(Reporter)

Comment 8

10 months ago
Not seen any more, we can reopen if it happens again.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(philipp)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.