console.log within a rAF callback hangs the browser

RESOLVED WORKSFORME

Status

DevTools
Console
RESOLVED WORKSFORME
a year ago
a month ago

People

(Reporter: dietrich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Nightly Mac OS X 55.0a1 (2017-04-15) (64-bit)

STR:

1. open a page with a console.log statement inside an requestAnimationFrame callback

Expected: Browser stays responsive

Actual: Browser stays slow but responsive for a few seconds and after that point must be force-killed.
Testing with a nightly build osx on this page and after opening the console it seems to keep logging as expected and I'm able to use the browser for other things without too much slowness:

data:text/html,<script>var i = 0; function foo() { console.log(i++, window); requestAnimationFrame(foo); } foo();</script>

Do you reproduce the hang with this URL?  Also, did you happen to have the Browser Console opened?
Flags: needinfo?(dietrich)
(Reporter)

Comment 2

a year ago
Hrm, I cannot reproduce on a clean profile. Then I tried again on my dirty profile and now cannot reproduce on latest nightly.

Also, I did a terrible job filing this bug, as I realized that's just as likely not rAF callback *alone*, and I had the devtools web console open (no browser console) and managed to forget to mention that.

So I'm going to close this for now, and re-open if I see it again :)
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dietrich)
Resolution: --- → WORKSFORME

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.