Closed Bug 1356883 Opened 3 years ago Closed 3 years ago

LastPass sites and show matching site menus don't work

Categories

(Firefox :: Extension Compatibility, defect)

55 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr45 --- unaffected
firefox52 --- unaffected
firefox-esr52 --- unaffected
firefox53 --- unaffected
firefox54 --- unaffected
firefox55 --- fixed

People

(Reporter: streetwolf52, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170414153533

Steps to reproduce:

Here's the regression range:

Bad
https://hg.mozilla.org/integration/mozilla-inbound/rev/b9a1e8ade106a8bce340b1717dea4870543536b9

Good
https://hg.mozilla.org/integration/mozilla-inbound/rev/32270cc5aeeafa676d43d47679ea87c580e665a7


Actual results:

LastPass icon on toolbar and it's context menu entry do not function.


Expected results:

Icon and context menu entry should function normally.
Component: Untriaged → Extension Compatibility
Problem has made it's way to Nightly.
Blocks: 1314861
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Keywords: regression
We no longer eagerly load panel views as soon as panels are created, and LastPass apparently depends on this. They should fix their code not to depend on it.
If it's a problem with LastPass can you contact them about how to fix it?  You have the expertise not me.
I opened up a ticket at LastPass support referencing this bug report.
Jorge, can you contact LastPass about this issue?
Jorge, can you contact LastPass about this issue?
Flags: needinfo?(jorge)
I also posted about this problem in their forum at https://forums.lastpass.com/viewtopic.php?f=12&t=253635
Or Andreas.
Flags: needinfo?(awagner)
Not having LastPass fully functional will essentially keep me at the last version of Nightly and Inbound where it works.  Therefore I won't be able to do any testing.  IDK if LastPass will make a change to a non-stable version of Fx.  If not is there a workaround for LP to work as it should?
Keywords: addon-compat
Keywords: addon-compat
It looks like this has already been escalated internally, per the link in comment #8.
Flags: needinfo?(jorge)
Flags: needinfo?(awagner)
(In reply to Jorge Villalobos [:jorgev] from comment #11)
> It looks like this has already been escalated internally, per the link in
> comment #8.

Based on my experience reporting problems to LastPass Support I wouldn't be surprised if nothing happens regarding this issue
Duplicate of this bug: 1357514
(In reply to Gary [:streetwolf] from comment #10)
> Not having LastPass fully functional will essentially keep me at the last
> version of Nightly and Inbound where it works.  Therefore I won't be able to
> do any testing.  IDK if LastPass will make a change to a non-stable version
> of Fx.  If not is there a workaround for LP to work as it should?

Almost - you can get all the functionality except the dropdown (and vault) access. To login, go to https://lastpass.com/ and login there. That will unlock your local vault. After that, the context menus handle almost anything.
(In reply to Kris Maglione [:kmag] from comment #2)
> We no longer eagerly load panel views as soon as panels are created, and
> LastPass apparently depends on this. They should fix their code not to
> depend on it.

Is there a bug for that work? I.e. something to show to Last Pass that this is not the result of a bug in a non-stable version, but rather a deliberate change that will ride the trains to production.
Flags: needinfo?(kmaglione+bmo)
It's from bug 1314861.
Flags: needinfo?(kmaglione+bmo)
FWIW...I just received an update to LP.  Had my fingers crossed it would fix the problem.  Alas, it didn't. Now logon information doesn't get auto filled as in the previous build.  Could be a bug in the new LP release.  Makes LP less usable now. New version is 4.1.46a

It is interesting to note that going back to the previous version which did fill in information doesn't work either.  I restored my profile that had this prior version in it. Perhaps it's a coincidence that I found out auto fill isn't working after I installed the new version. The problem might be with LP's servers.

I think getting this bug report fixed just went up a notch or two as far as priorities go. If the icon worked I'm hoping I can use it as before to fill in forms.
It is another patch on inbound that is causing the auto fill problem.  I'll try to get a regression range for you.
I found a workaround to open the context menu in the meantime:
Login in to lastpass.com then immediately log out.
Sorry I meant the icon.
The latest inbound doesn't have the auto-fill problem any more.
Duplicate of this bug: 1359114
Knowing that the LastPass developers sometimes take forever to fix things, is fixing this problem something I can do with relatively little experience?  I can make changes to code if I'm told what to change.
(In reply to Gary [:streetwolf] from comment #24)
> Knowing that the LastPass developers sometimes take forever to fix things,
> is fixing this problem something I can do with relatively little experience?
> I can make changes to code if I'm told what to change.

Unfortunately, no. This needs to be fixed in LastPass, and LastPass is not open source.
This is not relevant to the bug report at hand, but this is starting to rise in rank on Google, so for now if you're using the latest LastPass and Nightly, you can work around this problem to some degree by using the URL resource://support-at-lastpass-dot-com/data/vault.html to access the vault. Combined with the fact that autofill works fine now, this probably will hold most people over until LastPass figures it out on their end.
(In reply to John Chadwick from comment #26)
> you can work around this problem to some degree by using the URL
> resource://support-at-lastpass-dot-com/data/vault.html to access the vault.

Or regain "full" functionality by logging in/out of the lastpass.com website as mentioned in comment 20. (I use the dropdown a lot for launching sites.)
Is it just me or does it also affect the ability of the add on to load the binary component?
Flags: needinfo?(asteel)
LastPass dev here. I just fixed the icon toolbar button issue present in Firefox 55 and with that fix I was not able to recreate any issues with the context menu either. This ticket can hopefully be closed then once we release a new version. Thanks!
Duplicate of this bug: 1364083
I received the fixed version of LastPass from Andrew.  It is working just fine on Nightly. As far as I can tell it's not being offered anywhere so I don't know if this report should be closed.  I gave a couple of copies to some folks on Mozillazine and they report that it works fine too.
Could any of you (asteel@lastpass.com or garyshap@outlook.com ) attach the fixed version of LastPass to this bug please? 

I would like to test it for this Bug 1333990 

Thanks in advance!
Flags: needinfo?(garyshap)
Flags: needinfo?(garyshap)
Duplicate of this bug: 1364246
A. Steel provided me with a version of LP that fixed all the problems I've mentioned. I noticed today that a new version of LP is available, v4.1.53a. I installed this version. While it fixes all the problems in this report it also introduces a few more problems. When I click on the LP icon and from the menu select ‘Sites’ and ‘Show Matching Sites’ I am presented with an empty menu.
I can confirm that v4.1.53a fixes this issue, but it it still doesn't load the binary component (and I don't have Gary's problem)
I'm also seeing the issue reported in comment 34 with v4.1.53a.
Also, I see that issue for 53 release as well as on 55 Nightly. We may want to open a new bug for this.
Summary: LastPass icon and context menu doesn't work. → LastPass sites and show matching site menus don't work
Kris, is this a problem with LP or a problem on our side from bug 1314861 ?
Flags: needinfo?(kmaglione+bmo)
Shell, something we should be concerned about for the 55 release?
Flags: needinfo?(kmaglione+bmo) → needinfo?(sescalante)
With the latest version the menus show up again and autofill still works, so things aren't as bad as they were - but not being able to view or edit your saved passwords from the dropdown menu (forcing you to go to the vault) is pretty annoying. From comment #37 these issues show up across all versions of Firefox though, so this bug can probably be closed.

I just wish the LastPass devs were more on top of things; I'm surprised there hasn't been more noise about this (unless I'm just not seeing it).
Thanks Emanuel. Let's close this bug, but it would be good to file a new bug on the behavior you're describing. Can you do that?
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
(In reply to Emanuel Hoogeveen [:ehoogeveen] from comment #40)
> With the latest version the menus show up again and autofill still works, so
> things aren't as bad as they were - but not being able to view or edit your
> saved passwords from the dropdown menu (forcing you to go to the vault) is
> pretty annoying. From comment #37 these issues show up across all versions
> of Firefox though, so this bug can probably be closed.
> 
> I just wish the LastPass devs were more on top of things; I'm surprised
> there hasn't been more noise about this (unless I'm just not seeing it).

No you're not the only one, it's just that (despite being an Enterprise customer) I have given up reporting bugs to them: they always say they are already aware of it and have no ETA (I have reported fairly critical bugs months ago, still nothing...). And no one seems to care. So I guess other people may have given up too. I'm in the process of migrating to another solution.
We are working with Lastpass as they migrate to using webextension APIs.  WebExtension based add-ons are required for 57, which is entering Nightly in August (pref available in Nightly 57 [nightly only, goes away in Beta] to override WE requirement).  

Original bug sounds like it's gotten to the point that it isn't specific to 55 (with new LP version = new,less blocking issue but across Fx versions, which will get it's own bug).  

We'll want to make sure it isn't an issue with the Webextension version, but know they are working on the full migration to being webextension based and are working on when the final transition date is planned.
Flags: needinfo?(sescalante)
The menus are back for me too as of the June 14 LP update (4.1.53)
A user on MozillaZine is reporting that the new issues with the LP 4.1.53 don't show up in Firefox 54 [1]. I've been infernally busy so I haven't been able to investigate, but if true there's still a regression with Firefox 55.

[1] http://forums.mozillazine.org/viewtopic.php?p=14752940#p14752940
Removing needinfo flag.
Flags: needinfo?(asteel)
You need to log in before you can comment on or make changes to this bug.