If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No more output on console

UNCONFIRMED
Unassigned

Status

Thunderbird
General
UNCONFIRMED
5 months ago
5 months ago

People

(Reporter: Olivier R., Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170323105023

Steps to reproduce:

Since Thunderbird 52, the command `dump` doesn’t do anything anymore.
It was usefull to display message in the console we have if we launch Thunderbird with the option -console.

There was another console, but if we do:

    const xConsole = Cc["@mozilla.org/consoleservice;1"].getService(Ci.nsIConsoleService);
    xConsole.logStringMessage("a random string");

it doesn’t work either anymore.

AFAIK, there is now simply no way to a display a simple message.
This is particularly annoying. There is now no way to debug an extension.


Actual results:

Nothing. No output.


Expected results:

The console should show what we want to display.
(Reporter)

Comment 1

5 months ago
It seems I did something wrong previously… 

`xConsole.logStringMessage()` works.
`dump` still doesn’t.
Component: Untriaged → General

Comment 2

5 months ago
How about logging stuff to the error console? Components.utils.reportError() or Services.console.logStringMessage().
(Reporter)

Comment 3

5 months ago
Well, I used `Components.utils.reportError()` and `dump()`.
Now that I see I can log what I need in the error console, I’m OK with it.

I don’t know if `dump()` deserves to be fixed… It’s up to you.
Did you have browser.dom.window.dump.enabled set to true?
(Reporter)

Comment 5

5 months ago
No. I never set this option to true.
I just tried. Same result. No output with `dump()`.
My OS is Windows 7.
You need to log in before you can comment on or make changes to this bug.