Implement or update support for exposure of aria-orientation

RESOLVED FIXED in Firefox 56

Status

()

Core
Disability Access APIs
RESOLVED FIXED
7 months ago
5 months ago

People

(Reporter: Joanmarie Diggs, Assigned: Joanmarie Diggs)

Tracking

(Blocks: 1 bug)

unspecified
mozilla56
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 months ago
In ARIA 1.1, aria-orientation was added to the following roles with the specified implicit values:
* combobox: undefined
* listbox: vertical
* menu: vertical
* menubar: horizontal
* radiogroup: undefined
* tablist: horizontal
* toolbar: horizontal
* tree: vertical
* treegrid: undefined

In ARIA 1.1, the following changes related to aria-orientation were also made:
* aria-orientation's default value changed from horizontal to undefined
* separator now has implicit value of horizontal
* slider now has implicit value of horizontal

Please note, the following steps to reproduce only test a couple of roles for their implicit values. At the time of this report, automated tests to verify correct exposure are still being written.

Steps to reproduce:
1. Load data:text/html,<div role="treegrid" />
2. Use Accerciser to examine the state set of the accessible element
3. Load data:text/html,<div role="combobox" />
4. Use Accerciser to examine the state set of the accessible element

Expected result: The state set would not contain STATE_HORIZONTAL or STATE_VERTICAL for either test case, because neither orientation value is specified and the implicit value of aria-orientation for treegrid and combobox are "undefined."

Actual result: The state set contains STATE_VERTICAL for the two test cases.

Updated

7 months ago
Blocks: 343213
(Assignee)

Updated

5 months ago
Summary: Implement or update support for exposure of aria-orientation via ATK StateSet → Implement or update support for exposure of aria-orientation
(Assignee)

Comment 1

5 months ago
Created attachment 8879524 [details] [diff] [review]
proposed patch
Assignee: nobody → jdiggs
Status: NEW → ASSIGNED
Attachment #8879524 - Flags: review?(surkov.alexander)

Comment 2

5 months ago
Comment on attachment 8879524 [details] [diff] [review]
proposed patch

Review of attachment 8879524 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, thanks!
Attachment #8879524 - Flags: review?(surkov.alexander) → review+
(Assignee)

Updated

5 months ago
Attachment #8879524 - Flags: checkin+
(Assignee)

Comment 3

5 months ago
Comment on attachment 8879524 [details] [diff] [review]
proposed patch

Clearing the checkin flag. I thought that was "checkin needed". Sorry!
Attachment #8879524 - Flags: checkin+

Updated

5 months ago
Keywords: checkin-needed

Comment 4

5 months ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/343e7dbd5be2
Implement or update support for exposure of aria-orientation. r=surkov
Keywords: checkin-needed

Comment 5

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/343e7dbd5be2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
You need to log in before you can comment on or make changes to this bug.